Bug #35586

maxWInText dont work as expected

Added by Arno Dudek over 9 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2012-04-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I'm not shure if it's a bug or feature, but I remember it works differently in previous verions.

If maxWInText is set for example to 400, the column is 600 px wide and there is an image of 150 px, than the text should be 450 px. The CE is in this case a "Text & Images" and the "Position and Alignment" is set to "Beside Text, Left (or Right)". But now the margin-left property is 420 (textMargin = 20).

The margin will be calculated only by the maxWInText property and not by the image width.

Thanks!


Related issues

Related to TYPO3 Core - Bug #36541: in css hard-coded margin-left (or right) of 510px for "csc-textpic-text" in layout 25 and 26Closed2012-04-25

Actions
#1

Updated by Arno Dudek over 9 years ago

Is there any intention to fix this? Do you need more infos?

#2

Updated by Arno Dudek over 9 years ago

Found the problem now. It's part of the static TS of css_styled_content.

There is at 4.7

tt_content.image {

    20.layout.25.value = <div class="csc-textpic csc-textpic-intext-right-nowrap###CLASSES###">###IMAGES######TEXT###</div>
    20.layout.25.insertData = 1

    20.layout.26.value = <div class="csc-textpic csc-textpic-intext-left-nowrap###CLASSES###">###IMAGES######TEXT###</div>
    20.layout.26.insertData = 1
}

instead of

tt_content.image {

    20.layout.25.value = <div class="csc-textpic csc-textpic-intext-right-nowrap###CLASSES###">###IMAGES###<div style="margin-right:{register:rowWidthPlusTextMargin}px;">###TEXT###</div></div>
    20.layout.25.insertData = 1

    20.layout.26.value = <div class="csc-textpic csc-textpic-intext-left-nowrap###CLASSES###">###IMAGES###<div style="margin-left:{register:rowWidthPlusTextMargin}px;">###TEXT###</div></div>
    20.layout.26.insertData = 1
}

Will this be intended?

#3

Updated by Michael Bakonyi almost 9 years ago

I experience the same issue with 4.7.7. According to this issue #36541 the registers are not used anymore with 4.7. But it seems that the margin is calculated wrong with your mentioned positioning.

#4

Updated by Jost Baron over 7 years ago

Some more info: The margin is calculated by the first maxWInText that is found on the page. If that is set to some huge value (e.g. in a slider or by a content element using EXT:nwt_imagecrop), all later rendered "image beside text" content elements will have the same huge margin applied to the text part, except if the image dimensions on the later content element are set explicitely.

#5

Updated by Mathias Schreiber over 6 years ago

  • Target version set to 7.2 (Frontend)
  • Is Regression set to No
#6

Updated by Benni Mack over 6 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)
#7

Updated by Susanne Moog about 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#8

Updated by Benni Mack about 6 years ago

  • Target version changed from 7.5 to 7 LTS
#9

Updated by Mathias Schreiber almost 6 years ago

  • Status changed from New to Closed

won't fix, since we are moving to Fluid Rendering of CEs

Also available in: Atom PDF