Bug #36822

Invalid shortcut target on translated pages

Added by Arek van Schaijk almost 8 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Content Rendering
Target version:
Start date:
2012-05-03
Due date:
% Done:

100%

TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Since I have updated my multi language site from 4.5.x to 4.7, menu items with page type shortcut are not linked anymore in alternative languages (there isn't a href attribute on the link tag). The shortcut links in the default language are working well.

It seems that the Shortcut target in the Alternative Page Language record does not fallback to default anymore.

I have to fillin all shortcut targets in Alternative Page Language records to get it fixed.

Is it a bug in 4.7 or are there some settings for it? Do I have to report it on forge.typo3.org (where)?


Related issues

Related to TYPO3 Core - Bug #67047: Cannot access shortcut target in menus Closed 2015-05-20
Follows TYPO3 Core - Feature #17037: Better Shortcut for pages Closed 2007-02-24

Associated revisions

Revision adac6161 (diff)
Added by Oliver Hader about 6 years ago

[BUGFIX] Invalid shortcut target on translated pages

A feature to resolve shortcut links directly in menu rendering
does not consider the overlay behaviour of the "shortcut" value.

TSFE first uses the "shortcut" value of the original/default
page and then serves for possible translated alternatives
(TypoScriptFrontendController::checkTranslatedShortcut()).
In menu rendering it's the other way round, the translated
overlay (if any) is used directly - the fallback to use the
"shortcut" value of the original/default page is not implemented.

This change introduces the fallback when rendering menus, which
will take the "shortcut" value of the default language if the
value in the overlay is empty.

Change-Id: I26a9eb4813c6b99327043b0a764ec7ff80b6a905
Fixes: #36822
Releases: 6.2, 6.1
Reviewed-on: https://review.typo3.org/12765
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Wouter Wolters
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind

Revision c72e9019 (diff)
Added by Oliver Hader over 5 years ago

[BUGFIX] Invalid shortcut target on translated pages

A feature to resolve shortcut links directly in menu rendering
does not consider the overlay behaviour of the "shortcut" value.

TSFE first uses the "shortcut" value of the original/default
page and then serves for possible translated alternatives
(TypoScriptFrontendController::checkTranslatedShortcut()).
In menu rendering it's the other way round, the translated
overlay (if any) is used directly - the fallback to use the
"shortcut" value of the original/default page is not implemented.

This change introduces the fallback when rendering menus, which
will take the "shortcut" value of the default language if the
value in the overlay is empty.

Change-Id: I26a9eb4813c6b99327043b0a764ec7ff80b6a905
Fixes: #36822
Releases: 6.2, 6.1
Reviewed-on: http://review.typo3.org/27676
Reviewed-by: Oliver Hader <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

Revision f9badf9b (diff)
Added by Mathias Brodala 4 months ago

[BUGFIX] Fix translated shortcut target in menus

This ensures that the target of translated "shortcut" pages is
properly available. Normally this value is lost due to language
overlay thus the original page record needs to be retrieved to
restore the original shortcut target.

Now it is possible to e.g. mark shortcut menu items as active
on translated pages.

Resolves: #67047
Related: #36822
Releases: master, 9.5
Change-Id: I2cabc252ba1936763d6cbe1fe0a093aa74f5a4e1
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/39630
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Susanne Moog <>
Reviewed-by: Benni Mack <>
Reviewed-by: Susanne Moog <>

Revision 9735a3ac (diff)
Added by Mathias Brodala 4 months ago

[BUGFIX] Fix translated shortcut target in menus

This ensures that the target of translated "shortcut" pages is
properly available. Normally this value is lost due to language
overlay thus the original page record needs to be retrieved to
restore the original shortcut target.

Now it is possible to e.g. mark shortcut menu items as active
on translated pages.

Resolves: #67047
Related: #36822
Releases: master, 9.5
Change-Id: I2cabc252ba1936763d6cbe1fe0a093aa74f5a4e1
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62477
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Reviewed-by: Susanne Moog <>

History

#1 Updated by Oliver Hader over 7 years ago

  • Status changed from New to Accepted
  • Assignee set to Oliver Hader
  • Target version set to 4.6.11
  • TYPO3 Version changed from 4.7 to 4.6

#2 Updated by Oliver Hader over 7 years ago

Requirements:

  • different languages
  • a shortcut page with a specified target page in default language
    • localization of the shortcut page, but keeping the target blank there
  • a page (as referenced as shortcut target) in default language
    • localization of that page to test the results

Description:

A feature to resolve shortcut links directly in menu rendering does not consider the overlay behaviour of the "shortcut" value.
The mentioned feature has been introduced in TYPO3 4.6 - see #17037

TSFE first uses the "shortcut" value of the original/default page and then serves for possible translated alternatives (tslib_fe::checkTranslatedShortcut()).
In menu rendering it's the other way round, the translated overlay (if any) is used directly - the fallback to use the "shortcut" value of the original/default page is not implemented.

Since up to TYPO3 4.5, TSFE resolved those shortcuts, there has not been any problem.

#3 Updated by Oliver Hader over 7 years ago

  • Subject changed from Shortcut targets in Alternative Page Language doesnt fallback anymore to the default target in TYPO3 4.7 to Invalid shortcut target on translated pages

#4 Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/12763

#5 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/12764

#6 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12765

#7 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/12764

#8 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/12763

#9 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12765

#10 Updated by T. Lau over 7 years ago

I applied the Patch set 2 onto my Typo3 installation, but it does not work if shortcut mode is "First subpage of selected/current page". It only works if a shortcut page was selected.

#11 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12765

#12 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/12764

#13 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/12763

#14 Updated by Gerrit Code Review about 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/12765

#15 Updated by Markus Klein about 6 years ago

  • Target version changed from 4.6.11 to next-patchlevel
  • Is Regression set to No

#16 Updated by Gerrit Code Review about 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/12765

#17 Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27676

#18 Updated by Oliver Hader about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#19 Updated by Mike Streibl about 6 years ago

This patch doesn´t work when I changed the pagetype from shortcut to standard in the translation.

#20 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF