Feature #37939

displayCond should allow multiple conditions/checks

Added by Stefan Neufeind about 10 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2012-06-12
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

In some cases it would be good to have at least basic support for multiple conditions. Since afaik multiple displayCond-entries in flexform are a problem, we would need to find a syntax within one displayCond-entry to check for two or more things at once (if "a selected and b selected" or so).


Related issues

Related to TYPO3 Core - Bug #37938: Using HTML5 for audio not (easily) possible due to flexformClosed2012-06-12

Actions
Is duplicate of TYPO3 Core - Feature #18211: Array of display conditions for TCA fields instead of 1 stringClosed2008-02-14

Actions
#1

Updated by Georg Ringer about 10 years ago

isnt't that a duplicate of #18211?

#2

Updated by Stefan Neufeind about 10 years ago

about #18211: Sort of, I agree. Didn't find that one until now.

The only point is that you can't write "arrays" into flexform-XML. So if 18211 goes in imho we'd need to check it can also be configured in XML-notation. Leave this here as a separate bug for follow-up after the other thing is merged? Or add a comment to 18211 and close this one here as duplicate?

#3

Updated by Jigal van Hemert about 10 years ago

  • Status changed from New to Needs Feedback

@Stefan: what do you mean by 'you can't write "arrays" into flexform-XML'? Arrays are used for making selectorbox items:

<config>
    <type>select</type>
    <items type="array">
        <numIndex index="0" type="array">
            <numIndex index="0">Label1</numIndex>
            <numIndex index="1">Value1</numIndex>
        </numIndex>
        <numIndex index="1" type="array">
            <numIndex index="0">Label2</numIndex>
            <numIndex index="1">Value2</numIndex>
        </numIndex>
    </items>
</config>
#4

Updated by Stefan Neufeind about 10 years ago

Oh yes sure, it's doable that way. I just wasn't sure how those nested displayCond-statements would look like. It could work / be made working :-)

#5

Updated by Christian Kuhn over 9 years ago

  • Status changed from Needs Feedback to Resolved

Resolved as dupe of #18211 for now.

#6

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF