Project

General

Profile

Actions

Bug #38896

closed

Core: Exception handler (WEB) and Showpic.php

Added by Akif Sahin about 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Reports
Target version:
-
Start date:
2012-07-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

Hi,
after upgrade of Typo3 Version 4.4.x to 4.5.x i got errors like this:

Core: Exception handler (WEB): Uncaught TYPO3 Exception: Parameter Error: Wrong parameters sent. | UnexpectedValueException thrown in file .../typo3_src-4.5.17/typo3/sysext/cms/tslib/showpic.php in line 187

The Error is flooding my Backend and causes performance issues if it happens several times in succession.

I read in the Web about the problem and also given instructions here: http://forge.typo3.org/issues/26893#change-123322 and here:
http://www.typo3forum.net/forum/typo3-4-x-installation-updates/53163-core-exception-handler-web-showpic-php-line-173-a-2.html#post177998

But the answers are no solution for the still existing problem.

If I disable the Error Handling, then the error still occurs and in fact it is possible, that my server is getting to much flooded. Showpic.php is causing performance issues because of this.

Also i tried the given instructions in the forums but after a few days, still nothing changed.

I also do not understand, why this very hard error is marked as solved. That is no solution.

thanks for any help and hope the bug will be fixed.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #39052: Send sane HTTP response in showpic on errorClosed2012-07-18

Actions
Related to TYPO3 Core - Bug #26893: BE Log is flooded with "Parameter Error: No file or no parameters given." from showpic.phpClosedChris topher2011-05-18

Actions
Actions #1

Updated by Gerrit Code Review about 12 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12794

Actions #2

Updated by Stanislas Rolland about 12 years ago

Please test this change: http://review.typo3.org/12794 and give your vote in gerrit.

You may have to adapt the offset of the change since it is built against the master branch.

Actions #3

Updated by Stanislas Rolland almost 12 years ago

  • Status changed from Under Review to New
Actions #4

Updated by Benni Mack over 9 years ago

  • Status changed from New to Needs Feedback
  • Is Regression set to No

Does Stanislas' info help you and solve your problem?

Actions #5

Updated by Benni Mack over 9 years ago

  • Assignee set to Benni Mack
Actions #6

Updated by Akif Sahin over 9 years ago

Benjamin Mack wrote:

Does Stanislas' info help you and solve your problem?

Hi Benjamin, the topic is over 2 years old. Thanks for asking. Yes, it helped.

Actions #7

Updated by Benni Mack over 9 years ago

  • Status changed from Needs Feedback to Closed
Actions

Also available in: Atom PDF