Project

General

Profile

Actions

Bug #26893

closed

BE Log is flooded with "Parameter Error: No file or no parameters given." from showpic.php

Added by Christian Tauscher about 13 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2011-05-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Core: Exception handler (WEB): Uncaught TYPO3 Exception: Parameter Error: No file or no parameters given. | UnexpectedValueException thrown in file /html/typo3_src-4.5.2/typo3/sysext/cms/tslib/showpic.php in line 173

TYPO3 V4.5.2
php V5.2.11

To exclude buggy EXT, I have deinstalled successively every EXT. Finally only belog and beuser was installed, and still the Error was logged.

The site was updated from V4.2 to V4.5 before.
On a test-Enviroment (similar to live but slightly different php is V5.3 there) no problems occured. Changing the php Version on Live-Server to 5.3.2 had no effect.

All EXT are updated to latest Version, Exept tt_news (still last 2.4, but no difference if installed or not).

Maybe this is only by accident, but look at the time. 95% of this Messages apear every 10-11 Sec. There is NO cronjob installed and scheduler is not installed, too. No difference if BE user is loged in or not.

00:10:26 [0]@LIVE [5] Sys! [5_0] Core: Exception handler (WEB): Uncaught TYPO3 Exception: Parameter Error: No file or no parameters given. | UnexpectedValueException thrown in file /html/typo3_src-4.5.2/typo3/sysext/cms/tslib/showpic.php in line 173
00:10:15 Sys! Core: Exception handler (WEB): Uncaught TYPO3 Exception: Parameter Error: No file or no parameters given. | UnexpectedValueException thrown in file /html/typo3_src-4.5.2/typo3/sysext/cms/tslib/showpic.php in line 173
00:10:05 Sys! Core: Exception handler (WEB): Uncaught TYPO3 Exception: Parameter Error: No file or no parameters given. | UnexpectedValueException thrown in file /html/typo3_src-4.5.2/typo3/sysext/cms/tslib/showpic.php in line 173
00:09:55 Sys! Core: Exception handler (WEB): Uncaught TYPO3 Exception: Parameter Error: No file or no parameters given. | UnexpectedValueException thrown in file /html/typo3_src-4.5.2/typo3/sysext/cms/tslib/showpic.php in line 173
00:09:45 Sys! Core: Exception handler (WEB): Uncaught TYPO3 Exception: Parameter Error: No file or no parameters given. | UnexpectedValueException thrown in file /html/typo3_src-4.5.2/typo3/sysext/cms/tslib/showpic.php in line 173
00:09:34 Sys! .....


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #24453: showpic.php causes a fatal error if parameters GET variable is not an arrayClosedSteffen Ritter2011-01-02

Actions
Related to TYPO3 Core - Bug #39052: Send sane HTTP response in showpic on errorClosed2012-07-18

Actions
Related to TYPO3 Core - Bug #38896: Core: Exception handler (WEB) and Showpic.phpClosedBenni Mack2012-07-12

Actions
Actions #1

Updated by Chris topher about 13 years ago

  • Subject changed from BE Logtable is flooded with Error to BE Log is flooded with "Parameter Error: No file or no parameters given." from showpic.php

As the error message already says: This error occurs, when the script is called without the needed get/post variables.

Maybe a stupid robot which calls the script with wrong or without parameters?
I don't know how that could be prevented.

What you could do is disable error handling by setting this in localconf.php:

$TYPO3_CONF_VARS['SYS']['productionExceptionHandler'] = '';
$TYPO3_CONF_VARS['SYS']['debugExceptionHandler'] = '';
$TYPO3_CONF_VARS['SYS']['errorHandler'] = '';

Then you at least do no longer get the messages in the log.

Actions #2

Updated by Christian Tauscher about 13 years ago

  • % Done changed from 0 to 100

Christopher you are the best!

Checking the apache-logfiles I could detect a single ip that causes the Error by calling showpic.
with "deny from ip-adr" in my .htaccess the flooding stopped!

Thank you a Lot.

Christian :-)

P.S.: How to set this issue to "resolved"?

Actions #3

Updated by Chris topher about 13 years ago

Christian Tauscher wrote:

Christopher you are the best!

Thank you! :-)

P.S.: How to set this issue to "resolved"?

A know someone who can do that... ;-)

Actions #4

Updated by Chris topher about 13 years ago

  • Status changed from New to Resolved
  • Assignee set to Chris topher
Actions #5

Updated by Felix Nagel over 12 years ago

I was able to get rid of this problem by adding this to my htaccess:

RewriteCond %{QUERY_STRING} eID=tx_cms_showpic
RewriteRule ^ %{REQUEST_URI}? [R=301]

Actions #6

Updated by Dietmar von Schuetz over 12 years ago

The RewriteCond in htaccess lead to disabling the clickenlarge-Feature for pictures in the text, which I need.
The problem still persists in Typo3 4.5.8.

Therefore I had another try, this time with robots.txt:

User-agent: * 
Disallow: /typo3/ 
Disallow: /showpic.php

There are some people working on this problem and sharing experiences in a German forum: http://www.typo3forum.net/forum/typo3-4-x-installation-updates/53163-core-exception-handler-web-showpic-php-line-173-a.html

Could the status of this issue be set back to something like "not resolved"/"not closed" please?

Actions #8

Updated by Akif Sahin about 12 years ago

Hi,
i used the hints here and also the hints in the german forum mentioned above, but the error does still occur and, not just that only, i think the bug is a way to make typo3-sites slower. The problem is still not solved, the hints are useless. The wrong parameters comes mostly from spiders of google, bing or yahoo. There must be another way. It is obviously clear, that the problem is still open, because in the web everybody is searching for a working solution.

Please open this thread again and let us search together for a solution. How it is possible that this problem is nearly ignored?

Actions #9

Updated by Benni Mack almost 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF