Bug #39317

Copying records with IRRE: subrecords only copied in Live Workspace

Added by Andreas Kiessling over 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2012-07-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When a record with IRRE subrecords (in my case 1:n) is copied in a workspace, copies of the IRRE records are only created in the live workspace.
The created record in the workspace does not have any inline records attached.

An even bigger problem is publishing the record after adding new IRRE records: Since the existing records are not flagged as "deleted", the live record now has the "old" copied records AND the newly created ones merged together.

You can test this behaviour in 4.7 e.g. with the "irre_tutorial" extension:
Copy "Wellness Well-Being Hotel Rosengarten" on the "1:n foreign_field" page in a workspace, add a new "offer" and publish it.

The biggest problem comes up with the new content elements in 6.0 that use the inline relations to sys_file (tested with Introduction package of alpha3):
While the backend preview of the "Text with Image" shows the images of a copied content element (this is probably an additional bug with the generated preview showing the LIVE content), the content element itself has no images attached and after publishing the same merging of live and workspace inline records happens.

4.5 also seems to have the same bug


Related issues

Is duplicate of TYPO3 Core - Task #29278: Lost relations on copying IRRE children in workspacesRejected2011-08-26

Actions
#1

Updated by Oliver Hader almost 8 years ago

  • Category set to Bugs
  • Status changed from New to Closed
  • Assignee set to Oliver Hader

Please use issue #29278 which provides a bug-fix as well (currently for 4.7 and 4.5 only that will be forward ported soon).

#2

Updated by Michael Stucki almost 7 years ago

  • Category changed from Bugs to Workspaces
#3

Updated by Michael Stucki almost 7 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF