Task #29278

Epic #55070: Workpackages

Epic #54851: WP: Workspaces IRRE & MM bugfixes

Story #54853: As a user I want to correctly create, modify, preview and publish IRRE & MM related workspace changes

Task #56376: Invalid relations of IRRE records in workspaces

Lost relations on copying IRRE children in workspaces

Added by Anonymous about 8 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2011-08-26
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
hard
Sprint Focus:

Description

Hi there,

I figured out somekind of real big and ugly bug.

When using IRRE in an extension like powermail, the child fields won't get created in the workspace mode.

I thinks that since Workspace is part of the core now, this kind of has got its place here.

Here how to reproduce:

Install powermail (don't event need to configure highly)

  1. Create a content element of type powermail
  2. Create a fieldset
  3. Create a field in this fieldset
  4. Set a recipient (since it's somekind of needed in some versions)

Now go to workspace mode. Copy the element and paste it. You can be a adminstrator or normal TYPO3 user, this doesn't matter. When you open the newly copied element, you'll see, that the element has no fieldset nor fields and they aren't in the database though.

What I firgured out:
- The content get's processed properly
- The fields of the child elements get processed, event the child elements of the content child element
- for some reason, there is nothing written to the child tables.

I tested this with the latest trunk version of class.t3lib_tcemain.php of TYPO3 4.5.3

I'll continue watching out for a solution, but since I didn't find yet the point where it get's problematic, I'm not very confident...

Thanks for your support.

Greets Tizian


Related issues

Related to TYPO3 Core - Task #45676: Workspace references are not considered Rejected 2013-02-20
Related to TYPO3 Core - Task #45132: Faulty translation behavior of IRRE using workspaces Rejected 2013-02-04
Related to TYPO3 Core - Task #45214: Problems on publishing complex IRRE structure Closed 2013-02-06
Duplicated by TYPO3 Core - Bug #39317: Copying records with IRRE: subrecords only copied in Live Workspace Closed 2012-07-27

History

#1 Updated by Ingmar Schlecht about 8 years ago

  • Assignee set to Oliver Hader

@Olly, do you think this is an IRRE core bug with workspaces, or is it due to wrong TCA configuration from powermail?

~ friendly ghost

#2 Updated by Oliver Hader over 6 years ago

  • Status changed from New to Accepted
  • Target version set to 4.5.23

#3 Updated by Oliver Hader over 6 years ago

In general there are some issues that need to be tackled (all on workspaces)

localization of IRRE parent records and related children

Localization works like copying internally and thus at the end gets back to the copy logic.

discarding elements on workspaces

That's the most funny thing that, since discarding/deleting element is basically the same as creating a copy, but with accordant data to set deleted flags (the delete placeholder).
All actions that are related to that need to use versionizeRecord() for dependent children.

copying IRRE parent records and related children

The copy logic tries to determine whether a "copy action" is a localization or a real copy of an accordant parent.
If on workspaces, currently versionizeRecord() is used which just creates a new version, but without using a placeholder - thus, there is no indication that it's a plain new record and not related to to any existing record. This means, that versionizeRecord() only shall be used if this was the initial command (the indication is done by using the $workspaceOptions) array.

resolving concrete version record instead of placeholder record

In case the parent record was copied on a workspace, then this results in a new-placeholder which is overlaid by the concrete version in the workspace.
In any kind all children need to point to the concrete version instead of the placeholder record.

#4 Updated by Oliver Hader over 6 years ago

  • Subject changed from Copying contents using IRRE in Workspace loses child elements to Lost relations on copying IRRE children in workspaces

#5 Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17587

#6 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17587

#7 Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17587

#8 Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17902

#9 Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17587

#10 Updated by Gerrit Code Review over 6 years ago

Patch set 5 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17587

#11 Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/18046

#12 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17902

#13 Updated by Gerrit Code Review over 6 years ago

Patch set 6 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17587

#14 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/18046

#15 Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17902

#16 Updated by Gerrit Code Review about 6 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17902

#17 Updated by Oliver Hader over 5 years ago

  • Parent task set to #54853
  • Is Regression set to No

#18 Updated by Oliver Hader over 5 years ago

  • Assignee deleted (Oliver Hader)

#19 Updated by Oliver Hader over 5 years ago

  • Status changed from Under Review to Needs Feedback

#20 Updated by Oliver Hader over 5 years ago

  • Status changed from Needs Feedback to On Hold

#21 Updated by Oliver Hader over 5 years ago

  • Parent task changed from #54853 to #56376

#22 Updated by Oliver Hader over 5 years ago

  • Status changed from On Hold to Rejected

Solved with issue #56376

Also available in: Atom PDF