Bug #40359

Task #40095: Move core to namespaces

T3edit doesn't save changes

Added by Nicole Cordes over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
Start date:
2012-08-29
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

False function prevents t3edit to save templates.


Related issues

Related to TYPO3 Core - Bug #39860: Not possible to save edited files in fileadmin (TYPO3 6.0 Alpha3) Closed 2012-08-16

Associated revisions

Revision 190a8546 (diff)
Added by Nicole Cordes over 7 years ago

[BUGFIX] Fix saving changes in T3editor

Patch repairs ajax ids and class reference for t3editor so templates can
be saved again.

Change-Id: I730d28e1a4b2291bb6c98ac696b74518e820f206
Fixes: #40359
Relates: #40095
Releases: 6.0
Reviewed-on: http://review.typo3.org/14172
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

History

#1 Updated by Nicole Cordes over 7 years ago

If there is an error an alert "Object [Object]" is returned. It's generated in line 188 alert(T3editor.lang.errorWhileSaving);. I don't know if this is caused by the lang module.

#2 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14172

#3 Updated by Florian Seirer over 7 years ago

I just had the same error on TYPO3 4.7.4.

#4 Updated by Christian Kuhn over 7 years ago

  • Parent task set to #40095

#5 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14172

#6 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14172

#7 Updated by Gerrit Code Review over 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14172

#8 Updated by Gerrit Code Review over 7 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14172

#9 Updated by Nicole Cordes over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF