Project

General

Profile

Actions

Bug #40416

closed

Not wellformed output of AdminPanel (xhtml)

Added by anybody no-lastname-given almost 12 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Code Cleanup
Target version:
Start date:
2012-08-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:
Remote Sprint

Description

If you are running your Typo3 Site as "application/xhtml+xml" (I needed hours to find a possibility for running a Typo3 Site in that mode) and are using the AdminPanel in the FE, there comes an error message, that the line

if (document.addEventListener && !/opera/.test(navigator.userAgent.toLowerCase())) {

is not wellformed ("wohlgeformt")

Actions #1

Updated by anybody no-lastname-given almost 12 years ago

It seems not to be only the Admin Panel, but this failure appears always, when you are in the backend with the same browser.

Actions #2

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.2 (Frontend)
  • Is Regression set to No
Actions #3

Updated by Anja Leichsenring over 9 years ago

  • Sprint Focus set to On Location Sprint
Actions #4

Updated by Benni Mack about 9 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)
Actions #5

Updated by Susanne Moog almost 9 years ago

  • Complexity set to medium
Actions #6

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #7

Updated by anybody no-lastname-given almost 9 years ago

Some idea:

Perhaps it works, if in the case of use of config.xhtmlDoctype the java-Script is encapsulated in


<![CDATA[

....

]]>

It was also the solution for some not working scripts.

PS: It seems to be connected with the workspaces sysext

Actions #8

Updated by Anja Leichsenring almost 9 years ago

  • Sprint Focus changed from On Location Sprint to Remote Sprint
Actions #9

Updated by Benni Mack over 8 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #10

Updated by Benni Mack over 8 years ago

  • Target version changed from 7 LTS to 8 LTS
Actions #11

Updated by Georg Ringer over 8 years ago

  • Status changed from New to Closed

in the meantime, the admin panel is outputted into the body tag and produces valid html. I haven't found any bugs in any projects in this regard (using however html5 as doctype).

therefore I will close this issue. feel free to reopen if still valid for you in 7 LTS.

Actions

Also available in: Atom PDF