Project

General

Profile

Actions

Feature #41713

closed

Consider localizeReferencesAtParentLocalization for group/db

Added by Oliver Hader almost 12 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2012-10-08
Due date:
% Done:

100%

Estimated time:
PHP Version:
5.3
Tags:
Complexity:
medium
Sprint Focus:

Description

Currently the TCA config property localizeReferencesAtParentLocalization for database relations is only supported for select types with an accordant foreign_table defined. However, the whole procedure is valid but not checked for group/db fields as well.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #94570: Tests missing for localizeReferencesAtParentLocalizationClosed2021-07-16

Actions
Actions #1

Updated by Gerrit Code Review almost 12 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15399

Actions #2

Updated by Oliver Hader over 10 years ago

  • Parent task set to #54853
  • Is Regression set to No
Actions #3

Updated by Oliver Hader over 10 years ago

  • Status changed from Under Review to Needs Feedback
Actions #4

Updated by Oliver Hader over 10 years ago

  • Status changed from Needs Feedback to On Hold
Actions #5

Updated by Oliver Hader over 10 years ago

  • Status changed from On Hold to Accepted
  • Assignee set to Oliver Hader
  • Target version deleted (6.0.0-RC1)
  • TYPO3 Version changed from 6.0 to 6.2
Actions #6

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/15399

Actions #7

Updated by Gerrit Code Review over 9 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/15399

Actions #8

Updated by Andreas Krämer over 9 years ago

I am having just this problem with group/db and mm relations. Patch set 3 worked fine for me (TYPO3 6.2.5, PHP 5.3), but I needed to remove " && empty($mmTable)" in line 3317. Could you include a proper solution for group/db with mm relations?

Actions #9

Updated by Gerrit Code Review over 9 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/15399

Actions #10

Updated by Andreas Wolf almost 9 years ago

@Andreas Otto † Krämer: could you please post your exact TCA configuration of the parent field? This would greatly help in reproducing your issue.

Actions #11

Updated by Gerrit Code Review almost 9 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/15399

Actions #12

Updated by Gerrit Code Review almost 9 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/15399

Actions #13

Updated by Gerrit Code Review almost 9 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/15399

Actions #14

Updated by Andreas Wolf almost 9 years ago

I fixed the error mentioned by Andreas Krämer, and also added some more functional tests.

Actions #15

Updated by Oliver Hader almost 9 years ago

  • Category set to DataHandler aka TCEmain
  • Target version set to 7 LTS
Actions #16

Updated by Oliver Hader almost 9 years ago

  • Target version changed from 7 LTS to 7.5
  • Sprint Focus set to Stabilization Sprint
Actions #17

Updated by Benni Mack almost 9 years ago

  • Target version deleted (7.5)
  • Sprint Focus deleted (Stabilization Sprint)
Actions #18

Updated by Gerrit Code Review over 8 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #19

Updated by Gerrit Code Review over 8 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #20

Updated by Gerrit Code Review almost 8 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #21

Updated by Gerrit Code Review almost 8 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #22

Updated by Benni Mack over 6 years ago

  • Parent task deleted (#54853)
Actions #23

Updated by Oliver Hader over 6 years ago

  • Tracker changed from Task to Feature
  • Status changed from Under Review to Accepted
Actions #24

Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #25

Updated by Gerrit Code Review over 6 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #26

Updated by Gerrit Code Review over 6 years ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #27

Updated by Gerrit Code Review over 6 years ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #28

Updated by Gerrit Code Review over 6 years ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #29

Updated by Gerrit Code Review over 6 years ago

Patch set 17 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #30

Updated by Gerrit Code Review over 5 years ago

Patch set 18 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #31

Updated by Gerrit Code Review over 5 years ago

Patch set 19 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #32

Updated by Gerrit Code Review over 5 years ago

Patch set 20 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/15399

Actions #33

Updated by Gerrit Code Review over 4 years ago

Patch set 21 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/15399

Actions #34

Updated by Gerrit Code Review almost 3 years ago

Patch set 22 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/15399

Actions #35

Updated by Gerrit Code Review almost 3 years ago

Patch set 23 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/15399

Actions #36

Updated by Gerrit Code Review almost 3 years ago

Patch set 24 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/15399

Actions #37

Updated by Gerrit Code Review almost 3 years ago

Patch set 25 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/15399

Actions #38

Updated by Gerrit Code Review over 2 years ago

Patch set 26 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/15399

Actions #39

Updated by Gerrit Code Review over 2 years ago

Patch set 27 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/15399

Actions #40

Updated by Gerrit Code Review over 2 years ago

Patch set 28 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/15399

Actions #41

Updated by Christian Kuhn over 2 years ago

  • Related to Task #94570: Tests missing for localizeReferencesAtParentLocalization added
Actions #42

Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72102

Actions #43

Updated by Christian Kuhn over 2 years ago

Re-pushed as https://review.typo3.org/c/Packages/TYPO3.CMS/+/72102 since the former one is broken in gerrit and can't be commented.

Actions #44

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72102

Actions #45

Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72102

Actions #46

Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72102

Actions #47

Updated by Gerrit Code Review over 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72102

Actions #48

Updated by Gerrit Code Review over 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72102

Actions #49

Updated by Gerrit Code Review over 2 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72102

Actions #50

Updated by Andreas Wolf over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #51

Updated by Benni Mack almost 2 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF