Bug #42010

Extension manager should clear code cache when installing extensions

Added by Dmitry Dulepov over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2012-10-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When installing/uninstalling extensions, code cache should be cleared because it contains obsolete information. For example, do this:
- Uninstall Help>About extension in the EM
- Clear all caches manually
- Install Help>About extension
- Go to Help>About module (refresh BE if you do not see it on the left - another bug is reported about it already!)
- See the exception: "#1289386765: Could not analyse class:Tx_About_ViewHelpers_SkinImageViewHelper maybe not loaded or no autoloader?"
- Clear all cache
- Go to Help>About again - now works as expected


Related issues

Related to TYPO3 Core - Bug #41300: Exception after uninstalling DBALClosed2012-09-23

Actions
Is duplicate of TYPO3 Core - Bug #43381: ClassLoader error after installing extensionClosedOliver Hader2012-11-28

Actions
#1

Updated by Dmitry Dulepov over 8 years ago

Btw, I know about "clearcacheonload" but it is different. It was more related to FE caching (pages, TS cache, etc). EM should always clear code cache when installing extensions. Earlier we had code cache as typo3conf/temp_CACHED_* only and it was always cleared. Now we need to clear the new code cache.

#2

Updated by Christian Kuhn over 8 years ago

  • Status changed from New to Closed
  • Target version set to 6.0.1
  • % Done changed from 0 to 100
  • PHP Version set to 5.3

solved with #43381

Also available in: Atom PDF