Bug #43381

ClassLoader error after installing extension

Added by Oliver Hader almost 7 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
Start date:
2012-11-28
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

When e.g. installing tt_news version 3.4.0 (compatible to TYPO3 CMS 6.0.0) a fatal error will be shown since tt_news uses a class in ext_tables.php that requires the autoloader's registry information.

The following happens on installing an extension:
  • flushing the caches (including the class loader cache)
  • redirecting to list view of extension manager
  • triggering shutdown method in ClassLoader
  • updating cache if $cacheUpdateRequired is set

This updates the autoloader registry with old data since the extension's ext_autoload.php has not been considered at that time.

The issue is fixed by explicitly calling a new refresh method in the ClassLoader.


Related issues

Duplicated by TYPO3 Core - Bug #42010: Extension manager should clear code cache when installing extensions Closed 2012-10-15
Duplicated by TYPO3 Core - Bug #41300: Exception after uninstalling DBAL Closed 2012-09-23
Duplicated by TYPO3 Core - Bug #40596: Fatal error on installation of an extension Closed 2012-09-04

Associated revisions

Revision ea8e74d8 (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] ClassLoader error after installing extension

When e.g. installing tt_news version 3.4.0 (compatible to
TYPO3 CMS 6.0.0) a fatal error will be shown since tt_news
uses a class in ext_tables.php that requires the autoloader's
registry information.

The following happens on installing an extension:
  • flushing the caches (including the class loader cache)
  • redirecting to list view of extension manager
  • triggering shutdown method in ClassLoader
  • updating cache if $cacheUpdateRequired is set

This updates the autoloader registry with old data since
the extension's ext_autoload.php has not been considered at
that time.

The issue is fixed by explicitly reloading the ClassLoader
cache after TYPO3_LOADED_EXT has been reloaded.

Change-Id: Ifd2240bf004dbdfd34ded76618a5650f7af08d0e
Fixes: #43381
Releases: 6.0, 6.1
Reviewed-on: http://review.typo3.org/16832
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision ef426db6 (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] ClassLoader error after installing extension

When e.g. installing tt_news version 3.4.0 (compatible to
TYPO3 CMS 6.0.0) a fatal error will be shown since tt_news
uses a class in ext_tables.php that requires the autoloader's
registry information.

The following happens on installing an extension:
  • flushing the caches (including the class loader cache)
  • redirecting to list view of extension manager
  • triggering shutdown method in ClassLoader
  • updating cache if $cacheUpdateRequired is set

This updates the autoloader registry with old data since
the extension's ext_autoload.php has not been considered at
that time.

The issue is fixed by explicitly reloading the ClassLoader
cache after TYPO3_LOADED_EXT has been reloaded.

Change-Id: Ifd2240bf004dbdfd34ded76618a5650f7af08d0e
Fixes: #43381
Releases: 6.0, 6.1
Reviewed-on: http://review.typo3.org/16893
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16832

#2 Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16832

#3 Updated by Gerrit Code Review almost 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16832

#4 Updated by Gerrit Code Review almost 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16832

#5 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at http://review.typo3.org/16893

#6 Updated by Oliver Hader almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF