Bug #42279

RECORDS content object does not fetch translations for pages

Added by Helmut Hummel over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2012-10-22
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The RECORDS content object does a versioning and language overlay, but does not take the pages table into account.

Use the following TS to reproduce:

page.1 = RECORDS
page.1.source = 1
page.1.tables = pages
page.1.dontCheckPid = 1
page.1.conf.pages = TEXT
page.1.conf.pages {
field = title
htmlSpecialChars = 1
}

Even if page id is translated to a different language, the value of the default language is used.


Related issues

Related to TYPO3 Core - Bug #19275: TypoScript objects CONTENT and RECORDS do not respect localization of table pages Closed 2008-09-02
Duplicates TYPO3 Core - Bug #28564: Language overlay for RECORDS Closed 2011-07-29

Associated revisions

Revision baf6f475 (diff)
Added by Helmut Hummel over 7 years ago

[BUGFIX] Fix translation overlay in RECORDS

When RECORDS content object is used with pages as table
no translation overlay is done.

Fix that by adding a check and selecting the proper
overlay method in this case.

Resolves: #42279
Releases: 4.5, 4.6, 4.7, 6.0

Change-Id: I9be903c06abe8532390f814e2ff29825003359d7
Reviewed-on: http://review.typo3.org/15885
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer
Reviewed-by: Mattias Nilsson
Tested-by: Mattias Nilsson
Reviewed-by: Markus Klein
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

Revision 3bbde9e3 (diff)
Added by Helmut Hummel almost 7 years ago

[BUGFIX] Fix translation overlay in RECORDS

When RECORDS content object is used with pages as table
no translation overlay is done.

Fix that by adding a check and selecting the proper
overlay method in this case.

Resolves: #42279
Releases: 4.5, 4.6, 4.7, 6.0

Change-Id: I9be903c06abe8532390f814e2ff29825003359d7
Reviewed-on: https://review.typo3.org/17184
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision 73fbbbc0 (diff)
Added by Helmut Hummel almost 7 years ago

[BUGFIX] Fix translation overlay in RECORDS

When RECORDS content object is used with pages as table
no translation overlay is done.

Fix that by adding a check and selecting the proper
overlay method in this case.

Resolves: #42279
Releases: 4.5, 4.6, 4.7, 6.0

Change-Id: I9be903c06abe8532390f814e2ff29825003359d7
Reviewed-on: https://review.typo3.org/17182
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15885

#2 Updated by Helmut Hummel over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Thorsten Kahler over 7 years ago

Please don't backport this change: it will surely break existing sites!

#4 Updated by Helmut Hummel over 7 years ago

Thorsten Kahler wrote:

Please don't backport this change: it will surely break existing sites!

Can you please give examples what will break?

#5 Updated by Thorsten Kahler over 7 years ago

Maybe you can figure out by yourself what will happen if you don't get the pages record (any more) you requested (configured/selected/...) but a translation of it in the current language...

Fixing this bug in released versions would change a behaviour which exists since many TYPO3 versions.

#6 Updated by Karsten Nowak (undkonsorten) over 7 years ago

I'd like to use the patch, but i don't found the folder "frontend" in my sysext folder.
My TYPO3 version is 4.7.7

#7 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF