Bug #42762

preg_split wrong modifier in t3lib_softrefpro

Added by Franz Holzinger about 9 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-11-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

After saving of the TypoScript this error message is produced:

PHP Warning: preg_split(): Unknown modifier '\' in /var/www/domain/web/typo3_src-4.7.5/t3lib/class.t3lib_softrefproc.php line 561


Related issues

Related to TYPO3 Core - Bug #42454: Fix usage of fileadminDirClosed2012-10-28

Actions
Is duplicate of TYPO3 Core - Bug #41962: Wrong escapted RegEx in core/Classes/Database/SoftReferenceIndex.phpClosedTolleiv Nietsch2012-10-13

Actions
#1

Updated by Stefan Galinski about 9 years ago

  • Status changed from New to Accepted

Just got the very same error while saving user/group typoscript.

#2

Updated by Marc Bastian Heinrichs about 9 years ago

Fixed with #42454

#3

Updated by Georg Ringer almost 7 years ago

  • Status changed from Accepted to Resolved
  • Is Regression set to No

as stated, this should be fixed. feel free to open if still valid for you with 6.2

#4

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF