Bug #42812

Most checkboxes (like Extended View) are not working due to javascript bug

Added by Michael Späth about 8 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-11-09
Due date:
% Done:

100%

Estimated time:
1.00 h
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Typo3 Version 4.5.21

t3lib/class.t3lib_befunc.php

Before:

// $onClick = 'jumpToUrl(' . t3lib_div::quoteJSvalue($script . '?' . $mainParams . $addparams . '&' . $elementName) . '=+(this.checked?1:0),this);';

After:

$onClick = 'jumpToUrl(' . t3lib_div::quoteJSvalue($script . '?' . $mainParams . $addparams . '&' . $elementName . '=') . '+(this.checked?1:0),this);';

Just shift the "=" into the quoting.


Related issues

Has duplicate TYPO3 Core - Bug #42822: List view - show extended view & show localization view javascript errorClosed2012-11-09

Actions
Has duplicate TYPO3 Core - Bug #42890: Regression: Javascript error in Backend (jumpToUrl)Rejected2012-11-12

Actions
Has duplicate TYPO3 Core - Bug #42881: Show Clipboard stops showingClosed2012-11-12

Actions
#1

Updated by Matthias Nitsch about 8 years ago

It's also appearing in 4.7.6

#2

Updated by Andreas Kiessling about 8 years ago

Thank you for the fix Michael!

#3

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/16371

#4

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/16375

#5

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/16376

#6

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/16375

#7

Updated by Michael Späth about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Ernesto Baschny about 8 years ago

Since this is a pretty nasty regression, we should release new versions ASAP.

#9

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF