Bug #42849

Could not get the extensionlist in RC1

Added by Stephan Herold about 9 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2012-11-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I open the "Get Extensions"-Tab at a fresh installation, the called UpdateFromTerController.php produced a fatal at line 107, cause the $repository->getLastUpdate() is null.

107: if ($repository->getLastUpdate()->getTimestamp() < $GLOBALS['EXEC_TIME'] - 24 * 60 * 60 || $forceUpdateCheck) 

Respond from UpdateFromTerController.php

Fatal error:  Call to a member function getTimestamp() on a non-object in /var/www/virtual/multi.heroldhansen.de/htdocs/typo3/sysext/extensionmanager/Classes/Controller/UpdateFromTerController.php on line 107

Related issues

Related to TYPO3 Core - Bug #41620: Extension-Manager fails updating the Extension List on a fresh InstallationRejected2012-10-05

Actions
#1

Updated by Oliver Hader over 8 years ago

  • Target version set to 2222
#2

Updated by Oliver Hader over 8 years ago

  • Project changed from 2269 to TYPO3 Core
#3

Updated by Oliver Hader over 8 years ago

  • Category set to Extension Manager
#4

Updated by Oliver Hader over 8 years ago

  • Target version deleted (2222)
#5

Updated by Anja Leichsenring over 8 years ago

  • Status changed from New to Rejected

Fixed in the meantime.

#6

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Rejected to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19628

#7

Updated by Sascha Egerer over 8 years ago

Steps to reproduce:

  1. truncate table tx_extensionmanager_domain_model_extension
  2. go to the extension manager
  3. update extension list
#8

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19628

#9

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19628

#10

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/19629

#11

Updated by Anonymous over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#12

Updated by Christian Kuhn over 8 years ago

  • Status changed from Resolved to New
#13

Updated by Christian Kuhn over 8 years ago

This patch had to be reverted with https://review.typo3.org/#/c/19651/ and https://review.typo3.org/#/c/19654/

It triggered quite some side effects (especially in tests) that need to be resolved, before it could be merged again. After 2 hours of fixin, it still was not possible to get running tests on travis (which are not always reproducible in own environments, probably because of different error handling settings):

  • The em utility classes should not implement SingletonIntefaces
  • There are not mocked dependencies in some tests
  • Some em classes are instantiated with makeInstance() instead of the objectManager, thus those classes can not get things injected and do things in __construct() instead. This is an issue especially with the singleton thing. This can not be solved easily, as parts of install tool and packages (gov, intro) rely on using makeInstance at some places
  • Utilities need to be discoupled better (do not call repositories for example) and must be more stupid.
  • Maybe some parts of the uitilities should be services instead that are better encapsulated?

Quite some refactorings need to be done here.

#14

Updated by Mathias Schreiber almost 7 years ago

  • Status changed from New to Closed
  • Is Regression set to No

works as expected

Also available in: Atom PDF