Bug #43033

Clicking page title leads to page settings

Added by Mario Rimann almost 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2012-11-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.4
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Tested on a 6.0.0rc1 installation, logged in as admin user:

Steps to reproduce

- Go to List module
- Click on the root of the tree (that contains two standard pages in my case)
- The list module is shown in the right pane and lists two pages
- Click on the title of one of those pages

Expected

The list module of that clicked page is shown (with it's contents)

Current behaviour

Instead of the list module, the form for editing the page settings are shown

#1

Updated by Patrick Broens almost 9 years ago

  • Category set to Backend API
  • Target version set to 6.0.0
  • Complexity set to easy
#2

Updated by Mario Rimann almost 8 years ago

I can still reproduce this one on 6.1.5 - any pointer where in the "Backend API" something needs to be adjusted for this to be optimized?

#3

Updated by Riccardo De Contardi over 6 years ago

Still present on 6.2.x, not only for the pages in root.

#4

Updated by Riccardo De Contardi over 6 years ago

  • Is Regression set to No

But..is this really a bug? clicking on the title of every record in the list module opens that record for editing...

#5

Updated by Benni Mack over 6 years ago

  • Status changed from New to Needs Feedback

This is actually not a bug, but streamlined with the other record types: On click in the list module, you can edit the record directly.

#6

Updated by Mario Rimann over 6 years ago

I just looked into this issue again. I see the point that its streamlined with the behaviour of $whatever record in the list module.

But still I think it's not what I expect upon clicking the name of a page. I also dont expect to get to the edit form of a non-page record, but there I could better agree with this functionality, as it won't contain sub-records (except IRRE records). But IMO this is something different with a page wich is by design a container for content elements. So I'd still prefer to get to the list of subpages/content-elements of a page when clicking the page's name in the list module.

But I agree to what our UI experts and the bigger part of the audience agrees to.

#7

Updated by Riccardo De Contardi over 6 years ago

Is the option

mod.web_list.clickTitleMode

Related?
According to the documentation http://docs.typo3.org/typo3cms/TSconfigReference/PageTsconfig/Mod/Index.html

Default is that pages will go one level down while other records have no link at all.

Can someone test what it actually does?

#8

Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (6.0.0)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF