Bug #43088

No mails and an error when switching to live

Added by Ingo Pfennigstorf about 9 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2012-11-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When switching to live as admin since 4.7.6 our editors get an error and no mails are sent (see attachment). The new contents do appear in the frontend as it seems.
The error message is sent by router:
Address in mailbox given [@localhost] does not comply with RFC 2822. 3.6.2


Related issues

Related to TYPO3 Core - Bug #43148: Workspace NotificationsClosed2012-11-20

Actions
#1

Updated by Marco Bresch about 9 years ago

  • Status changed from New to Needs Feedback

Hi Ingo,
Do you have some more information about your environment?
Do you have version and workspaces installed or version only?
Do you have any notification settings?

Maybe this bug is related to #42948

Cheers
Marco

Btw.: Did you forget the attachment?

#2

Updated by dermueller no-lastname-given about 9 years ago

I can confirm this issue. Version AND Workspace is installed. Notification settings are configured. Happens since the update to TYPO3 4.7.7.

Update: I think I have traced this down a bit: see t3lib/mail/class.t3lib_mail_swiftmaileradapter.php on line 73 public function mail(). The first argument $to is defined as string ("@param string $to Email address to send the message to"), because a few lines later it will be given to $toAddresses = $this->parseAddresses($to), which also waits for a string ("@param string $rawAddresses Comma separated list of email addresses (optionally with display name)").

But in fact, if you debug the contents of $to, it's an array that is given to public function mail() instead of a string. So this can't work. And calling $toAddresses = $this->parseAddresses($to) breaks the e-mail-addresses, falling back to @localhost as the default "private $default_domain = 'localhost'" from t3lib/mail/class.t3lib_mail_rfc822addressesparser.php. The @localhost address is then given to $this->message->setTo($toAddresses);, which explains this part of the error message.

#3

Updated by Marco Bresch about 9 years ago

  • Status changed from Needs Feedback to Accepted

Sorry guys,
that was my fault. In october I submitted a patch in workspace which depends on a patch in version. The patch in workspace was merged but the patch in version was rejected by gerrit. I did not recognized the rejection by gerrit.

#4

Updated by Gerrit Code Review about 9 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch version_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/12045

#5

Updated by Marco Bresch about 9 years ago

  • Status changed from Under Review to Resolved
#6

Updated by Ingo Pfennigstorf about 9 years ago

Hi Marco,

sorry, the forge mails were filtered in my mail account - because there were far too many mails the last days. So I just didn't see this progress here.

Marco Bresch wrote:

Do you have some more information about your environment?

Sure, even it's not necessary anymore fore this issue ;) 4.7 on PHP 5.3.12

Do you have version and workspaces installed or version only?

both

Do you have any notification settings?

guess so, yes ;)

Btw.: Did you forget the attachment?

Yes ... but great you found the solution - I owe you some drinks next time we meet!

#7

Updated by Martin Kästner almost 9 years ago

I did have the same issue with TYPO3 4.7.7 and version+workspaces.
Why this patch is not being taken? It solves the bug for me.

See also #43148 which is a duplicate, I think.

bye
Martin

#8

Updated by Michael Stucki almost 8 years ago

  • Category changed from Bugs to Workspaces
#9

Updated by Michael Stucki almost 8 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
#10

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF