Bug #42948

Catchable fatal error using the developing area

Added by Kurt Kunig almost 10 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Workspaces
Target version:
Start date:
2012-11-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Since the last Upgrades of TYPO3 (also in version 4.5.22) an error message is coming up if you push the swap button (double arrow). The swap is realy done but you have to address the record once again in the list or page view, because the error message below is still shown in the working frame on the right.

This is the error meassage:
Catchable fatal error: Argument 7 passed to tx_version_tcemain::notifyStageChange() must be an array, null given, called in /html/typo3/typo3_src-4.5.22/typo3/sysext/version/class.tx_version_tcemain.php on line 181 and defined in /html/typo3/typo3_src-4.5.22/typo3/sysext/version/class.tx_version_tcemain.php on line 384


Related issues

Related to TYPO3 Core - Bug #26615: Many stage changes do NOT send email notificationsClosedMarco Bresch2011-05-04

Actions
Related to TYPO3 Core - Bug #33383: Add Comments when PublishingClosed2012-01-23

Actions
Related to TYPO3 Core - Bug #25434: Workspace state change notification email is always in englishClosed2006-07-19

Actions
#1

Updated by Patrick Broens over 9 years ago

  • Target version set to 4.5.23
  • Complexity set to medium
#2

Updated by Christian Kuhn over 9 years ago

There were only two patches in version since 4.5.20 ... i guess, one of them triggered this issue.

commit 40d3c347fbbeb9de5694b1d2a60491d4c595a326 - http://review.typo3.org/4519
commit dd0c7858dbfd2dee40e4b7a5cf59fd84438fe649 - http://review.typo3.org/12048

Markijan no-lastname-given: Would you like to take a look?

#3

Updated by Christian Kuhn over 9 years ago

  • Project changed from TYPO3 Core to 624
  • Category deleted (Backend User Interface)
#4

Updated by Christian Kuhn over 9 years ago

Added Marco as watcher ... maybe he can take a look at this.

#5

Updated by Marco Bresch over 9 years ago

  • Assignee set to Marco Bresch

Okay... I will try to reproduce this.

#6

Updated by Marco Bresch over 9 years ago

  • Status changed from New to Accepted

This bug exists in 4.6 too.

#7

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch 4.6 has been pushed to the review server.
It is available at http://review.typo3.org/16489

#8

Updated by Gerrit Code Review over 9 years ago

Patch set 2 for branch 4.6 has been pushed to the review server.
It is available at http://review.typo3.org/16489

#9

Updated by Gerrit Code Review over 9 years ago

Patch set 3 for branch 4.6 has been pushed to the review server.
It is available at http://review.typo3.org/16489

#10

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch 4.5 has been pushed to the review server.
It is available at https://review.typo3.org/18011

#11

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch version_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/18012

#12

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch version_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/18013

#13

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18014

#14

Updated by Wouter Wolters over 9 years ago

  • Status changed from Under Review to Resolved

Merged in all branches.

#15

Updated by Michael Stucki over 8 years ago

  • Category set to Workspaces
#16

Updated by Michael Stucki over 8 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
#17

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF