Project

General

Profile

Actions

Bug #43158

closed

Sorting of parent records also moves inline childs

Added by M. Stichweh over 11 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
Start date:
2012-11-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

If the sorting of a parent record is changed the move method in TCEMain is also called for all its child records (inline elements) recursivly. But for the child records the destination pid is the current page id, so the sorting of the childs is changed to be the first item on page. This is not the expected behaviour and also results in very bad performance. This can be disabled in TCA by the behaviour flag disableMovingChildrenWithParent but this also disables real moving to other pages.
On sorting the moving of childs should be disabled, since it does not make sense here.


Related issues 1 (1 open0 closed)

Related to TYPO3 Core - Bug #68040: Inline localize and/or synchronize does not respect sortingUnder Review2018-03-142018-03-14

Actions
Actions #1

Updated by Mathias Schreiber about 9 years ago

  • Target version set to 7.5
  • Is Regression set to No
Actions #2

Updated by Jo Hasenau over 8 years ago

Sorting elements in the background this way also leads to a weird behaviour of the l10nmgr export, which is currently purely based on the sorting field regardless of any nesting levels.

So you will get lots of child elements way before their respective parents in the XML file, which leads to serious context problem for the translators.

Actions #3

Updated by Benni Mack over 8 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #4

Updated by Mathias Schreiber over 8 years ago

  • Category set to DataHandler aka TCEmain
  • Target version changed from 7 LTS to 8 LTS
Actions #5

Updated by Benni Mack almost 7 years ago

  • Target version changed from 8 LTS to next-patchlevel
Actions #6

Updated by Oliver Hader over 6 years ago

  • Status changed from New to Accepted
  • Complexity set to medium
Actions #7

Updated by Tymoteusz Motylewski over 5 years ago

  • Status changed from Accepted to Closed

I believe this was fixed together with https://forge.typo3.org/issues/85304 in v9 and v8 (backport is waiting)
https://review.typo3.org/#/c/57259/

Actions

Also available in: Atom PDF