Bug #43241

rsa/saltedpasswords not installed by default

Added by Peter Kraume over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Authentication
Target version:
Start date:
2012-11-23
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I just did a new TYPO3 installation with TYPO3 6.0 RC2 (blankpackage). rsa/saltedpasswords were not installed by default as expected.

Associated revisions

Revision 61d45e42 (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] saltedpasswords not installed by default

Because of folder renaming the autoloader of saltedpasswords is not
executed anymore so rsa and saltedpasswords are not installed by default.

Change-Id: Ib4c950e77048f2fcbca20d0f7bf2a0b7f9f11a0e
Fixes: #43241
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19647
Reviewed-by: Alexander Opitz
Reviewed-by: Wouter Wolters
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision aa502f95 (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] saltedpasswords not installed by default

Because of folder renaming the autoloader of saltedpasswords is not
executed anymore so rsa and saltedpasswords are not installed by default.

Change-Id: Ib4c950e77048f2fcbca20d0f7bf2a0b7f9f11a0e
Fixes: #43241
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19659
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Helmut Hummel over 7 years ago

  • Status changed from New to Needs Feedback

saltedpasswords/rsa are not installed if the server requirements are not met, in particular if openssl is missing or misconfigured

if we would install them in that case, login would be impossible

#2 Updated by Peter Kraume over 7 years ago

Well, in that case the detection of the server requirements might have a problem since I was able to install saltedpasswords/rsa by hand without any problem.
I will check this again with the next installation of TYPO3 6.0

#3 Updated by Marcel Wieser over 7 years ago

Same here. saltedpasswords and rsaauth were not installed by default, but everything worked well after installation. Tested with the TYPO3 6.0 blankpackage.

#4 Updated by Torben Hansen over 7 years ago

Same problem here on a fresh Debian Squeeze server with all requirements met. Installing rsaauth and salted passwords manually works fine.

#5 Updated by Tilo Baller over 7 years ago

Same here.
saltedpasswords + rsaauth were not installed by default on a server where older typo3 version installed them by default before. Activating them in extension manager manually worked.

#6 Updated by Gerrit Code Review about 7 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19647

#7 Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/19659

#8 Updated by Nicole Cordes about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF