Bug #43792

IE9: Upgrade TYPO3 4.7.4 -> 4.7.7 makes BE crash when saving through RTE

Added by Bert Hiddink almost 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2012-12-09
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

I just updated several sites from 4.7.4 -> 4.7.7 and got feedback from clients that in IE9 only (!) when saving through RTE (hmtlarea latest version), the Backend and IE crashes completely. When logging back in, data are saved but got no idea why this upgrade makes IE crash.

I found out that the issues is related to the "compatibility mode": in Quirk mode (default), the BE and IE crashes after saving a RTE-field, in IE7 standard mode, there are now problemas with saving or crash.

This is what I get:
Problem signature:
Problem Event Name: APPCRASH
Application Name: iexplore.exe
Application Version: 9.0.8112.16455
Application Timestamp: 507284ba
Fault Module Name: MSHTML.dll
Fault Module Version: 9.0.8112.16455
Fault Module Timestamp: 50728e5d
Exception Code: c0000005
Exception Offset: 003a2478
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1043
Additional Information 1: 725a
Additional Information 2: 725a326504ffadb65750d96be10b582c
Additional Information 3: 2028
Additional Information 4: 2028533522579844d7f64ead43796f91

Regards,
Bert


Related issues

Related to TYPO3 Core - Bug #25165: IE8 Browser crashes as soon as content element is saved/closed Closed 2011-02-24
Duplicates TYPO3 Core - Bug #43766: IE9 crashes after saving with RTE Closed 2012-12-08

History

#1 Updated by Tilo Baller almost 7 years ago

Seems that this was just resolved with http://forge.typo3.org/issues/43766.

@Bert: Can you verify this?

#2 Updated by Bert Hiddink almost 7 years ago

Hello,

Just applied the suggested patch (http://forge.typo3.org/issues/43766) and this fixed the issue.

Thanks!!!

Bert

#3 Updated by Tilo Baller almost 7 years ago

Great to hear.

Can someone with the necessary privileges please close this issue. Thanks.

#4 Updated by Navi almost 7 years ago

  • Target version set to 4.5.23

This bug also appears to exists in 4.5.22. I'm experiencing the same issues!

Applying the above patch does not seem to fix the problem.

BE also seems to be running in IE8 mode? (when looking in the dev toolbar, actual browser is IE9)

#5 Updated by Stanislas Rolland almost 7 years ago

  • Status changed from New to Resolved

#6 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF