Bug #44109

ses_iplock IPv6

Added by Job Rutgers over 8 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-12-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

Although I setup in [FE][lockIP] to store the first 2 parts of my IP address, for a IPv6 the total address is stored into the db and used to check your session.


Related issues

Related to TYPO3 Core - Feature #62375: IPv6 session lock Closed2014-10-21

Actions
Is duplicate of TYPO3 Core - Bug #21638: IP-lock not aware of IPv6Closed2010-08-06

Actions
#1

Updated by Jigal van Hemert over 8 years ago

  • Status changed from New to Accepted
  • Complexity set to medium

IPlock assumes an IPv4 address (it splits on '.')

Maybe we should use a common format for IPv4 and IPv6 addresses? (Some nice conversions are done in http://stackoverflow.com/questions/12435582/php-serverremote-addr-shows-ipv6 )

This would probably be a feature and could only go in a new release.

#2

Updated by Job Rutgers about 7 years ago

Still not working in Typo3 6.2

#3

Updated by Riccardo De Contardi almost 6 years ago

  • Status changed from Accepted to Closed
  • Is Regression set to No

I close this as it is a duplicate of #21638, please continue the discussion there.

If you think that this is the wrong decision , then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF