Bug #44145

Additional TCA fields not available in the Frontend

Added by Alexander Stehlik over 8 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Frontend
Target version:
-
Start date:
2012-12-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Currently it is not possible, to access TCA data of additional fields in the Frontend (the problem at hand occurs when using tx_cssstyledcontent_pi1->render_uploads for a custom field in tt_content, the field does not exits in the TCA).

As far as I can see the problem is caused in tslib_fe->getCompressedTCarray.

The columns array key is removed completely in this method. When you don't have additional columns this is not a problem, because t3lib_div::loadTCA will read all column data from the configured dynamicConfigFile.

But when you define additional fields and add them with t3lib_extMgm::addTCAcolumns they will be ignored.

The easiest fix for this would be to not remove the columns array, when additional columns are configured.

This bug is present in version 4.5 and in version 6.0.


Related issues

Blocks TYPO3 Core - Bug #47796: css_styled_content does not render uploads anymoreClosed2013-05-01

Actions
#1

Updated by Alexander Stehlik over 8 years ago

Sorry, I digged into this a bit further and I realized this report is totally wrong. It is not a bug in the Frontend but in css_styled_content.

So please update the title to render_uploads() in css_styled_content loads TCA incorrectly.

When you look at \TYPO3\CMS\CssStyledContent\Controller\CssStyledContentController::render_uploads() you can see that it uses

\TYPO3\CMS\Core\Utility\GeneralUtility::loadTCA('tt_content');

In the docs of the loadTCA() method you can read:

Note: For the frontend this loads only 'ctrl' and 'feInterface' parts.

For complete TCA use $GLOBALS['TSFE']->includeTCA() instead.

So the call to loadTCA() should be changed to

$GLOBALS['TSFE']->includeTCA();
#2

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17250

#3

Updated by Georg Ringer over 8 years ago

  • Assignee set to Georg Ringer
#4

Updated by Alexander Stehlik over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/17715

#6

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17716

#7

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at https://review.typo3.org/17717

#8

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/17718

#9

Updated by Georg Ringer over 8 years ago

  • Status changed from Under Review to Resolved
#10

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF