Bug #47796

css_styled_content does not render uploads anymore

Added by Mario Matzulla over 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
Start date:
2013-05-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The render_upload function got changed in line:

t3lib_div::loadTCA('tt_content');
to
$GLOBALS['TSFE']->includeTCA();

This change does not consider configurations made to other extension TCA configurations inside tca.php.

Please revert this change.

It effects TYPO3 version 4.5.25 and 6.0.4 (not tested with 6.1.0)


Related issues

Blocked by TYPO3 Core - Bug #44145: Additional TCA fields not available in the FrontendClosedGeorg Ringer2012-12-20

Actions
#1

Updated by Patrick Broens about 8 years ago

6.1 should not have this problem. This line is taken out there.

#2

Updated by Michael Christian about 8 years ago

  • Target version set to 4.5.26

Could you please change the priority to "Must have".

The upload-FE rendering not working with "$GLOBALS['TSFE']->includeTCA();" - with "t3lib_div::loadTCA('tt_content');" everything is fine (at the FE).

Thank you.

#3

Updated by Michael Christian about 8 years ago

  • Assignee set to TYPO3 Release Team

Could you please fix the render upload error with V4.5.28.

#4

Updated by Benni Mack about 6 years ago

  • Status changed from New to Closed
  • Assignee deleted (TYPO3 Release Team)
  • Is Regression set to No

This one seems to be fixed. No problems with all supported versions anymore.

Also available in: Atom PDF