Bug #44386

tcaTree cannot handle records on pid 0 correctly

Added by Lorenz Ulrich over 8 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2013-01-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When using the tcaTree with nested records on pid 0, the parent handling does not work correctly.

The reproduce, you can e.g. allow the table sys_category on the root page by adding 'rootLevel' => -1 to its TCA configuration. Then go to some page (not root), add 3 cats:

foo
bar, set foo as parent
bar 2, set foo as parent

Then add a category to root level, open 'bar' or 'bar 2' again -> parent is not selected anymore.


Related issues

Related to TYPO3 Core - Feature #47530: sys_category should be globally availableClosed2013-04-24

Actions
Blocks TYPO3 Core - Bug #41634: Allow sys_category on the root pageClosed2012-10-06

Actions
#1

Updated by Andreas Wolf over 8 years ago

  • Category set to FormEngine aka TCEforms
  • Status changed from New to Accepted
  • Target version set to 6.0.1
#2

Updated by Andreas Wolf almost 8 years ago

  • Status changed from Accepted to Rejected

Note: sys_category is allowed on the root page by default now.

Also I could not reproduce this with latest master, therefore I'm closing it now.

Also available in: Atom PDF