Bug #44781

ConfigurationUtility->getCurrentConfiguration only delivers default configuration

Added by Sebastian Michaelsen over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2013-01-24
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TYPO3\CMS\Extensionmanager\Utility\ConfigurationUtility has a nice handy function getCurrentConfiguration($extensionKey), which tries to load the default configuration and overlay it with the current configuration. But due to an error it will always output the default configuration.

Using GeneralUtility::array_merge_recursive_overrule $defaultConfig should be overlayed with $currentExtensionConfig. The problem is that the two arrays have different formats.

$defaultConfig contains the array with information parsed from the typoscript (style) comments, the default values are nested in these informations.
$currentExtensionConfig contains a pure key value store for the configuration.
Also see the attached screenshot to see how the two array don't fit together.

I don't really know how to solve this properly. I would love to have a Utility Function that just returns a key value array, but at the moment the function returns the more verbose array. We can't really change this anymore, since this is public API isn't it?

There are two spots in the core at the moment that use this method, that could be adjusted, but there might already be 3rd party implementations using it.

Bildschirmfoto_2013-01-24_um_11.43.57.png View (35.4 KB) Sebastian Michaelsen, 2013-01-24 11:56


Related issues

Related to TYPO3 Core - Bug #44665: Configuration Utility loses extension key Closed 2013-01-19
Duplicates TYPO3 Core - Bug #42775: Saving one tab, deleted entries from other tabs Closed 2012-11-08

History

#1 Updated by Christian Kuhn over 6 years ago

  • Status changed from New to Closed

dupe of #42775

Also available in: Atom PDF