Bug #44887

Pasting multiple lines plain text results in line breaks (<br>) instead of paragraphs (<p>)

Added by Helmut Hummel over 8 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2013-01-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

Septs to reproduce:
Copy the following two lines plain text from a text editor into an RTE field:

Line 1
Line 2

Expected HTML

<p>Line 1</p>
<p>Line 2</p>

Actual HTML in IE (8.0) and FF (16.0.1)

Line 1<br />Line 2

Actual HTML in Chrome

<div>Line 1</div>
<div>Line 2</div>

After Saving:
<div><p>Line 1</p></div>
<div><p>Line 2</p></div>

#1

Updated by Stanislas Rolland about 8 years ago

In the backend, the expected result depends on the paste behaviour you have set in your BE User Settings.

If you selected, "Paste structure and basic format", then the result depends on where you are pasting from.

If you are pasting from a plain text editor (in which the notion of paragraph does not exist), the result will be, as expected:

Line 1<br />Line 2

After save, this will become:

<p>Line 1</p>
<p>Line 2</p>

If you are pasting from Open Office, the result will be:

<p>Line 1</p>
<p>Line 2</p>

This is the case in Firefox 22, Chrome 28 and Internet Explorer 10.

The paste operation may clean away some markup, depending on your settings, but it will not add markup that does not exist in the source text.

#2

Updated by Stanislas Rolland about 8 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Stanislas Rolland
#3

Updated by Alexander Opitz almost 8 years ago

  • Target version deleted (4.5.23)
  • Is Regression set to No

Hi Helmut,

is this issue still valid?

#4

Updated by Helmut Hummel almost 8 years ago

Stanislas Rolland wrote:

In the backend, the expected result depends on the paste behaviour you have set in your BE User Settings.

If you selected, "Paste structure and basic format", then the result depends on where you are pasting from.

If you are pasting from a plain text editor (in which the notion of paragraph does not exist), the result will be, as expected:
[...]

After save, this will become:
[...]

Hm, that would be OK, but this is not true for me.

This is the case in Firefox 22, Chrome 28 and Internet Explorer 10.

Tested in FF 25.0.1 and Chrome 31.0.1650.63 (on Mac OSX 10.9.1)

FF after paste:

Line 1<br />Line 2

FF after save:

<p>Line 1<br />Line 2</p>

Chrome after paste:

<div>Line 1</div>
<div>Line 2</div>

Chrome after save:

<div><p>Line 1</p></div>
<div><p>Line 2</p></div>

So, yes. This is still an issue for me.

#5

Updated by Alexander Opitz almost 8 years ago

  • Status changed from Needs Feedback to New
#6

Updated by Mathias Schreiber almost 7 years ago

  • Target version set to 7 LTS
#7

Updated by Riccardo De Contardi over 6 years ago

As far as I can see this behavior is due to RTEHtml area; I performed a test using http://htmlarea.sourceforge.net/examples/core.html and the results are:

Chrome 42.0.2311.135 (64-bit) on Mac OSX Yosemite:

<div>Line 1</div>
<div>Line 2</div>

Firefox 37.0.2 on Mac OSX Yosemite:

Line 1<br />Line 2

IE11 11.0.9600.17728 on Windows 8.1 64bit

Line 1<br />Line 2

Chrome 42.0.2311.135 on Windows 7 64bit:

<div>Line 1</div>
<div>Line 2</div>

Firefox 37.0.2 on Windows 7 64bit:

Line 1<br />Line 2

IE11 10.0.9200.17296 on Windows 7 64bit (IE9 emulation as in IE10 mode that page did not work)

<p>line 1<br />line 2</p>
#8

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from New to Closed

I close this as after all the tests I have performed it seems it is a behavior of HTMLarea; Maybe you could try to get in contact with the programmer of the HTMLArea.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#9

Updated by Stanislas Rolland over 6 years ago

  • Status changed from Closed to New
  • Complexity set to hard

TYPO3 is not using http://htmlarea.sourceforge.net/examples/core.html

TYPO3 htmlArea RTE has been completely rewritten.

#10

Updated by Mathias Schreiber almost 6 years ago

  • Target version deleted (7 LTS)
#11

Updated by Wolfgang Hamster over 5 years ago

  • Assignee changed from Stanislas Rolland to Helmut Hummel

Hello,
is there already a solution?
This problem occurs more often...

#12

Updated by Helmut Hummel about 4 years ago

  • Assignee deleted (Helmut Hummel)
#13

Updated by Riccardo De Contardi about 4 years ago

  • Status changed from New to Closed

Not reproducible on TYPO3 8.7.7 and CKEditor.

I performed a test with IE11, FF and Chrome (latest versions) on Windows7
result: the code is always saved as:

<p>LINE1<br />
LINE2</p>

We are sorry, but we close this issue as now TYPO3 uses CKEditor and RTEHtmlarea development has been stopped.

RTEHtmlarea has been decoupled from the core and its code is available on GitHub:
https://github.com/FriendsOfTYPO3/rtehtmlarea

If you still need this fixed please create a PR on GitHub

If you think that this is the wrong decision, please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF