Bug #46261

Indexing files does not store the language

Added by Mario Rimann over 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2013-03-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

By default, the files that get indexed are bound to a specific page ID, but the file in the index is not bound to a specific language. This results in showing / not showing the files in the wrong situations.

Setup:

  • Given a site with DE (L=0) as default and FR (L=1) as additional language
  • There is a page that links to files:
  • The German Page links to a file "DE.pdf" that contains the word "Deutsch"
  • The French Page links to a file "FR.pdf" that contains the word "fran├žais"
  • The page is being indexed via FE-Indexing, in both languages

Expected:

  • Searching for "Deutsch" should
  • find the "DE.pdf" file while searchin in the DE-Frontend
  • NOT find the "DE.pdf" file when searching in the FR-Frontend (as it's not linked to the FR-Page!)
  • Searching for "fran├žais" (with or without the special character, searching for "francais" results in the same behavior) should
  • find the "FR.pdf" file while searching in the FR-Frontend
  • NOT find the "FR.pdf" file when searching in the DE-Fronten (as it's not linked on the DE-page!)

Current Behavior:

All indexed files are only ever shown when searching in the default language - and of course only when they match the search term.

In the FR-page, no single file is being shown as search result - because the file is indexed/stored with "sys_language_uid == 0" in the database.

Proposed Change:

I'll add a patch soonish that just adds the sys_language_uid when storing an indexed file to the current sys_language_uid that is being used by TSFE. This works fine for us and solves the above mentioned issue and did not show any negative side-effects in several customer projects.

#1

Updated by Georg Ringer over 8 years ago

IMO sys_language_content should be used, not the uid itself to be able to care about fallbacks ?!

#2

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18899

#3

Updated by Oliver Hader about 8 years ago

  • Target version set to 2222
#4

Updated by Oliver Hader about 8 years ago

  • Project changed from 1382 to TYPO3 Core
#5

Updated by Oliver Hader about 8 years ago

  • Category set to Indexed Search
#6

Updated by Oliver Hader about 8 years ago

  • Target version deleted (2222)
#7

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18899

#8

Updated by Anonymous almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22333

#10

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/22334

#11

Updated by Anonymous almost 8 years ago

  • Status changed from Under Review to Resolved
#12

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/22347

#13

Updated by Mario Rimann over 7 years ago

We need a Release-Manager decision here, as only certain changes can go into 4.7.x - and that's the only thing that's still pending -> it's merged in master (6.2), 6.1 and 6.0 branches already.

#14

Updated by Frans Saris almost 7 years ago

  • Status changed from Under Review to Resolved
  • TYPO3 Version set to 6.2
  • Is Regression set to No
#15

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF