Bug #48813

Mailform with localization ignores the email-address of the translated record

Added by Albrecht Köhnlein over 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-03-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Sorry for this new issue. It's about the existing issue #17061 - But this original issue was already marked as completed and I was not sure about the correct behavior in this case. So I decided to open a new ticket.

In #17061, the problem was solved. But for TYPO3 4.5 this fix does not work. The used variables are $this->data, but should be $this->cObj->data, since there is an own class form

Sorry for that trouble, but I'm not very familiar with GIT, so I hope anybody else can submit a fix for this problem.

#1

Updated by dermueller no-lastname-given about 8 years ago

  • % Done changed from 100 to 0

I can confirm this: it still does not work with TYPO3 4.5. In typo3\sysext\cms\tslib\class.tslib_fe.php the function

$record = $this->sys_page->checkRecord([...])

does not return the language overlay correctly, so $record['subheader'] will always keep the value from the original language layer.

#2

Updated by Alexander Opitz about 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee deleted (Michael Stucki)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.2.15 or 7.6.0)?

#3

Updated by Bjoern Jacob about 6 years ago

IMHO we can close this issue. We do not support the old mailform anymore. The code has been moved to compat6. This is also no issue of EXT:form.

#4

Updated by Albrecht Köhnlein about 6 years ago

Feel free to close. As Bjoern wrote, the old 4.x form was completely replaced since 6.x

#5

Updated by Wouter Wolters about 6 years ago

  • Status changed from Needs Feedback to Closed

Thanks for reporting back. Closed as requested.

Also available in: Atom PDF