Project

General

Profile

Actions

Bug #49119

closed

Is Typoscript template versioned?

Added by Riccardo De Contardi almost 11 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
Start date:
2013-06-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

As per subject: should the Typoscript template have different versions in workspace?? Is it a bug?
I've seen in TYPO3 6.1.1 that the Typoscript template is different between LIVE/Workspsace version

in the table sys_workspaces the root template has a t3ver_label "Auto-created for WS #1" and there is a record with pid=-1

So, that's why my question: is it a bug or it is normal that TS template is being versioned in workspaces?
Thank you for your assistance

Actions #1

Updated by Oliver Hader almost 11 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (next-patchlevel)

At least since TYPO3 4.5 sys_template is enabled for versioning. Did you experience any difficulties with that?

Actions #2

Updated by Riccardo De Contardi almost 11 years ago

At least since TYPO3 4.5 sys_template is enabled for versioning. Did you experience any difficulties with that?

Well...as I always change the template in the LIVE workspace, I was wondering where the versioned and different version came from?

Actions #3

Updated by Michael Stucki over 10 years ago

  • Category changed from Bugs to Workspaces
Actions #4

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
Actions #5

Updated by Alexander Opitz about 10 years ago

  • Status changed from Needs Feedback to New
  • Is Regression set to No
Actions #6

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
Actions #7

Updated by Oliver Hader over 8 years ago

  • Status changed from New to Closed

The answer the the initial question is: Yes, sys_template records are versioned.
I'm closing this issue - please open another one with specific bug descriptions if you think something is wrong in that regard. Thx

Actions

Also available in: Atom PDF