Bug #49233

FAL Migration not applied to file links in tt_content bodytext

Added by Nico de Haen about 8 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-06-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

It seems that all file links in tt_content bodytext are not migrated to point to the corresponding sys_file record. They are migrated once you open the content element in the backend but not in the Install tool update wizard which cares only for files in tt_content.image.

This means, that all file links that are not yet migrated won't reflect renaming of folders and files. If the path of a file changed the content elements are not accessible anymore due to #37409

You can easily destroy a whole site by just renaming one folder in the file list module...

To make it clear:
After running the update wizard the links still look like this (can be seen only in the database):

<link fileadmin/Downloads2/MyFile.pdf - download "Initiates file download">MyFile</link>

but should look like this:
<link file:12345 - download "Initiates file download">MyFile</link>

I'm not sure if that is a regression or if it was always like this, since I didn't find any code for that in the update wizard.


Related issues

Related to TYPO3 Core - Bug #49212: File links from tt_content bodytext are not/wrong indexedClosed2013-06-18

Actions
#1

Updated by Francois Suter about 8 years ago

  • Status changed from New to Accepted
  • Assignee set to Francois Suter
  • Complexity set to medium
#2

Updated by Gerrit Code Review about 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22002

#3

Updated by Gerrit Code Review about 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22002

#4

Updated by Francois Suter about 8 years ago

You don't need to have a full TYPO3 installation to upgrade to test this patch. Here are some steps for testing (after having applied the patch):

1) pick some file in your fileadmin folder (say "foo/bar.pdf").
2) edit some tt_content element directly in a database tool and insert something like:

<link fileadmin/foo/bar.pdf>Test file link</link>

in the "bodytext" field.
3) update the sys_refindex index
4) go to the upgrade wizard, the File links update wizard should tell you that there's 1 link (at least) to update
5) run the File links update wizard. It should show the update queries.
6) check the content of the tt_content element in the database. The link should have been transformed to:
<link file:xxx>Test file link</link>

#5

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22134

#6

Updated by Francois Suter about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF