Bug #49212

File links from tt_content bodytext are not/wrong indexed

Added by Nico de Haen about 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-06-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This is quite similar to #48998 but the behaviour is a bit different. A file link in RTE is not converted by the migration tool and not indexed in frontend view/preview but only when an editor opens the content element in the backend and then it is indexed wrong as described in #49033. This means:
  1. the file link will work in frontend (since it contains the site relative path)
  2. if an editor opens the bodytext field in backend the file is indexed but with storage 0
  3. the file link will be broken if the file path changes (for example when renaming file or folder)
  4. even if the indexing would happen with the correct storage as long as the CE is not opened in backend the file link would not reflect renaming the file or path

To reproduce:

1. after running the migration tool all file links in bodytext still look like this:

<link fileadmin/Downloads/myfile.pdf _blank download>MyFile</link>

2. when opening the page in frontend this link works but the file is not indexed
3. when opening the content element in backend the bodytext the link looks like this:
<a href="http://www.mydomain.de/?file:1234" class="download" title="Initiates file download" _blank download>MyFile</a>
where 1234 is the uid of a new created entry in sys_file with storage = 0, which means the file is still not reflecting renaming of files and paths.

This is an absolute blocker for upgrading to 6.0 or 6.1 since there is no way to easy fix all wrong indexed files as long as not all bodytext fields containing file links are indexed.


Related issues

Related to TYPO3 Core - Bug #48998: FAL files get reindexed in storage null when used with tt_contentClosed2012-09-06

Actions
Related to TYPO3 Core - Bug #49233: FAL Migration not applied to file links in tt_content bodytextClosedFrancois Suter2013-06-19

Actions
#1

Updated by Nico de Haen about 8 years ago

Sorry I picked the wrong issue ID in the description. The "similar" issue is #48998 not #49033

#2

Updated by Georg Ringer about 8 years ago

changed issue number

#3

Updated by Steffen Ritter over 7 years ago

  • Status changed from New to Needs Feedback
  • Is Regression set to No

so we have a upgrade wizard for that now and double indexation is prevented...

still an issue

#4

Updated by Nico de Haen over 7 years ago

Is that a question or a statement?

#5

Updated by Alexander Opitz over 7 years ago

This was a question. ;)

#6

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (next-patchlevel)

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF