Project

General

Profile

Actions

Task #49319

closed

Epic #55070: Workpackages

Epic #54260: WP: FAL Missing Issues / Features / API

Story #54272: As an Editor I expect FAL to work with the RTE

Error finding folder for rte links preparing

Added by René Pflamm about 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-06-21
Due date:
% Done:

100%

Estimated time:
0.50 h
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Sprint Focus:

Description

I generated many tt_content objects with an script to migrate an old "Contenido"-CMS Page to TYPO3 6.1.

During editing the content to make it clear I noticed many errors while TYPO3 CMS tried to get images, and links passing to the <link >-Tag.

If the Object not found in the given Location it throws an uncaught Exception:

Folder cms/upload/file.ext does not exist.

or

Folder cms/front_content.php?id=123 does not exist.

of Course it doesn't... I created the Folder an uploaded any of the files from the old page. It worked for any image. But now, at saving the RTE Data it makes any Link from <a href="cms/frontend_content.php... to <link cms/frontend_content.php... > and then it throws the Exception described above at reopening the Content Element.

In the ResourceFactory I added an try and catch operation to prevent this error.

Because I think this could also happened when ssers entered an wrong link I would post my Patch for all here.

<small>sorry for my bad english ;)</small>


Files

ResourceFactory.patch (847 Bytes) ResourceFactory.patch René Pflamm, 2013-06-21 16:50
Actions #1

Updated by Chris topher about 11 years ago

  • Category set to File Abstraction Layer (FAL)
Actions #2

Updated by Steffen Ritter over 10 years ago

  • Parent task set to #54272
  • Is Regression set to No
Actions #3

Updated by Stanislas Rolland over 10 years ago

  • Estimated time set to 1.00 h
Actions #4

Updated by Stanislas Rolland over 10 years ago

  • Assignee set to Stanislas Rolland
Actions #5

Updated by Stanislas Rolland over 10 years ago

I am unable to reproduce this issue with current master.

Actions #6

Updated by Stanislas Rolland over 10 years ago

  • Status changed from New to Needs Feedback
Actions #7

Updated by Stanislas Rolland over 10 years ago

  • Estimated time changed from 1.00 h to 0.50 h
Actions #8

Updated by Stanislas Rolland over 10 years ago

  • % Done changed from 0 to 100
Actions #9

Updated by Steffen Ritter over 10 years ago

  • Status changed from Needs Feedback to Closed

I think this one can be closed,
a, Stan cant reproduce
b, if the author is linking to files the migration is wrong should have bin file:0:/cms/ ...

Actions

Also available in: Atom PDF