Project

General

Profile

Actions

Bug #50196

closed

Unit test errors in TYPO3\CMS\Core\Tests\Unit\Utility\File\ExtendedFileUtility

Added by Oliver Klee over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-07-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

This occurs on MacOS X with the build-in PHP 5.3. The apache user does not have root privileges.

Create new file in local storage
! Error in test case createNewFileInLocalStorage
File: /Users/klee/eclipse/typo3_src/typo3/sysext/core/Classes/Resource/Driver/LocalDriver.php
Line: 237
File /_unitTestedFile.txt does not exist.

Copy file in local storage
! Error in test case copyFileInLocalStorage
File: /Users/klee/eclipse/typo3_src/typo3/sysext/core/Classes/Resource/Driver/LocalDriver.php
Line: 237
File /_unitTestedFile.txt does not exist.
Copy folder in local storage

Actions #1

Updated by Markus Klein over 10 years ago

I recently investigated on this.

The reason is a superfluous /

touch("/var/www/html/master/fileadmin//_unitTestedFile.txt")
Actions #2

Updated by Philipp Gampe over 10 years ago

  • Status changed from New to Accepted
  • Target version set to next-patchlevel
  • Complexity set to no-brainer

@Markus can you push a patch for this?

Actions #3

Updated by Sebastian Fischer almost 10 years ago

Could it be that this test is replaced with TYPO3\CMS\Core\Tests\Functional\Utility\File\ExtendedFileUtilityTest ?

If yes this test case file is working.

Actions #4

Updated by Oliver Klee almost 10 years ago

These tests do not fail on my Mac anymore. So this ticket can be closed now.

Actions #5

Updated by Christian Kuhn almost 10 years ago

  • Status changed from Accepted to Resolved
  • Is Regression set to No
Actions #6

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF