Bug #50875

Install Tool feature "Create admin user" can't handle umlauts in username

Added by Markus no-lastname-given about 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2013-08-07
Due date:
% Done:

100%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Observed behaviour:
When a username like 'dörthe' is entered, the user will be created with the username 'drthe' instead. No warning or error message will reveal this to the user.
In the TYPO3 Backend there is no problem when a username with umlauts in it is created; it just works as expected.

Expected:
There should be one of the following:
- a warning, that the username is invalid or not possible via the Install Tool
- an error that the username could not be created as requested
- the username is accepted and set correctly


Related issues

Related to TYPO3 Core - Task #49162: Rewrite install tool Closed 2011-10-30

Associated revisions

Revision b83587f1 (diff)
Added by Georg Ringer over 4 years ago

[TASK] Harmonize allowed characters of backend usernames

When creating new backend users from the intall tool, any
character is now accepted for the username. Whitespaces get
trimmed and uppercase is converted to lowercase.
This is already the case for TCA of be_users.username

Change-Id: I0edabd2cb82dc59bdc52dd385c1e198f04be6017
Resolves: #50875
Releases: master
Reviewed-on: http://review.typo3.org/35997
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Christian Kuhn about 6 years ago

clearly a bug ... should be investigated.

#2 Updated by Philipp Bergsmann over 5 years ago

This also happens when the username includes a dash. E.g. "my-admin-user" would be renamed to "myadminuser" without notification

#3 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35997

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35997

#5 Updated by Steffen Müller over 4 years ago

  • Is Regression set to No
  • Sprint Focus set to On Location Sprint

#6 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36503

#7 Updated by Georg Ringer over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Anja Leichsenring almost 4 years ago

  • Sprint Focus deleted (On Location Sprint)

#9 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF