Project

General

Profile

Actions

Bug #51761

closed

PHP Warning for open_basedir in filelist for every file after updating 6.1.3 -> 6.1.4

Added by Simon Schick over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-09-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

I don't know in which change this was included ... but since the update to 6.1.4, I get a PHP Warning for every file listed there.

The warning is:
PHP Warning: is_dir(): open_basedir restriction in effect. File(/srv/http/domain.org/www/fileadmin/user_upload/someimage.jpg/) is not within the allowed path(s): (/srv/http/domain.org/:/srv/http/localhost/www/piwik/:/srv/http/typo3/:/srv/http/default/xhprof/:/srv/xhprof/:/usr/share/php/xhprof_lib/utils/) in /srv/http/typo3/typo3_src-6.1.4-patched/typo3/sysext/core/Classes/Resource/Driver/LocalDriver.php line 399

I don't know whether this is a PHP bug or not, but it just appears after updating to 6.1.4. After downgrading to 6.1.3, it disappeared.


Related issues 1 (0 open1 closed)

Has duplicate TYPO3 Core - Bug #51771: Warnings after upgrading to 6.0.9 and browsing filelist with open_basedir in useClosed2013-09-05

Actions
Actions

Also available in: Atom PDF