Bug #52066

Bug in TCA, label_alt not working in page module

Added by Jan-Hendrik Heuing over 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2013-09-17
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Adding a field as alternative label does not show up in the page module:

$TCA['tt_content']['ctrl']['label_alt'] = 'dummy_title,bodytext';

While dummy_title is shown in the list view (so it IS generally working), it's not in the page module.

List-module: http://dl.ivi-solutions.com/2013-09-17_1019.png
Page-module: http://dl.ivi-solutions.com/2013-09-17_1019-1.png

Debugging this, getRecordTitle() in BackendUtility.php is only called by the page table, not the content elements: http://dl.ivi-solutions.com/2013-09-17_1016.png, there seems to be no other place in the code to differenciate between label and label_alt fields, but I can be wrong of course.

History

#1 Updated by Philipp Gampe over 5 years ago

Can you come up with a patch? http://wiki.typo3.org/CWT

#2 Updated by Jan-Hendrik Heuing over 5 years ago

Nope, didn't get to the right entry point. I had a look as you see.

#3 Updated by Mathias Schreiber over 4 years ago

  • Target version changed from 6.2.0 to 7.4 (Backend)

#4 Updated by Susanne Moog almost 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#5 Updated by Benni Mack over 3 years ago

  • Target version changed from 7.5 to 7 LTS

#6 Updated by Mathias Schreiber over 3 years ago

  • Sprint Focus set to Stabilization Sprint

#7 Updated by Michael Oehlhof over 3 years ago

  • Status changed from New to Closed

Tested with the default tt_content configuration in master.
Activated the subheader in pageTSconfig and created a header CE with setting only the subheader field.
The text from the subheader field ist shown in the list view and also in the page view.

Also available in: Atom PDF