Project

General

Profile

Actions

Bug #52607

closed

Domain Model validators are executed twice

Added by Marc Bastian Heinrichs over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
Extbase
Target version:
Start date:
2013-10-08
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Fix for this needs to be backported from Flow

@see #49624


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #62500: Validator based on DataType of controller-action argument is added twiceClosed2014-10-27

Actions
Actions #1

Updated by Andreas Allacher about 10 years ago

Should be included before final v6.2 LTS

Currently the validators are called double. The issue was introduced most likely with this change:
https://git.typo3.org/Packages/TYPO3.CMS.git/commit/66fb0ad5c6755089db014cd329357898632bf444

because now the validator is found via buildMethodArgumentsValidatorConjunctions and buildBaseValidatorConjunction and added on both parts.

Actions #2

Updated by Online Now! GmbH almost 10 years ago

Bug is still present in TYPO3 6.2.4. Also if you add an annotation @validate with the validator before a controller action, the validator gets executed three times. Only workaround in the mean time is to put the validators not in the \Domain\Validator directory or modify the Extbase source code.

Actions #3

Updated by Alexander Opitz over 9 years ago

  • Project changed from 534 to TYPO3 Core
  • Category changed from Extbase: Validation to Extbase
  • Target version changed from Extbase 6.2 to next-patchlevel
  • TYPO3 Version set to 6.2
  • Is Regression set to No
Actions #4

Updated by Alexander Schnitzler over 9 years ago

  • Status changed from New to Accepted
  • Assignee set to Alexander Schnitzler
Actions #5

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36915

Actions #6

Updated by Anonymous over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #7

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37579

Actions #8

Updated by Anonymous over 9 years ago

  • Status changed from Under Review to Resolved
Actions #9

Updated by Alessandro Schmitz over 7 years ago

  • TYPO3 Version changed from 6.2 to 7

Looks like this bug is still in 7.6.x.
Having the same problem: Validator class inside the domain folder gets called twice and outside only once.

Actions #10

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF