Project

General

Profile

Actions

Task #53655

closed

Epic #55070: Workpackages

Epic #54260: WP: FAL Missing Issues / Features / API

Story #54267: As an Editor I want to use a FAL withouth bugs

Wrong path in Frontend on moving directory in fileadmin

Added by Stefan Weißwange over 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-11-15
Due date:
% Done:

100%

Estimated time:
0.00 h
TYPO3 Version:
6.1
PHP Version:
5.4
Tags:
Complexity:
medium
Sprint Focus:

Description

I have cut'n'pasted a folder in the fileadmin directory to another directory:
from /fileadmin/library/marketing/ to /fileadmin/library/resources/pr/marketing/.

Assets, used in content elements (fileadmin/library/marketing/image.png) which worked before the cut'n'paste dont show up afterwards, because the frontend is using a (partly) wrong path, the Image-Source references library/resources/pr/marketing/image.png. The fileadmin folder is missing in the path.

As a quick'n'dirty workaround if symlinked library to fileadmin/library, then the image is processed and displayed as accepted.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #54499: Fix test: LocalDriver does not update file-properties anymoreClosed2013-12-18

Actions
Actions #1

Updated by Stefan Weißwange over 10 years ago

To reproduce:
  1. Create a directory in fileadmin (fileadmin/Bibliothek/test/testlibrary/)
  2. Upload image in directory (image.png)
  3. Use image within textpic
  4. Image is processed like expected (<img src="/fileadmin/_processed/csm_image_935ce2192e.png" />_)
  5. Cut'n'Paste folder to another folder (fileadmin/Bibliothek/test/another_testfolder/testlibrary/)
  6. Reload Page in Frontend, imagepath is wrong and image does not show up (<img src="/Bibliothek/test/another_testfolder/testlibrary/image.png" />)
  7. create symlink in Document Root (ln -s fileadmin/Bibliothek/ Bibliothek)
  8. Image is processed like expected (<img src="/typo3temp/_processed/csm_image_935ce2192e.png" />_)
Actions #2

Updated by Markus Klein over 10 years ago

  • Status changed from New to Accepted
Actions #3

Updated by Frans Saris over 10 years ago

Could you test this with current master? I think #53614 fixed this issue. Can not reproduce the problem as you describe.

Actions #4

Updated by Frans Saris over 10 years ago

Just checked again, you're right. When moving the whole folder the hash values in sys_file aren't updated.

Actions #5

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25481

Actions #6

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25481

Actions #7

Updated by Steffen Ritter over 10 years ago

  • Target version changed from next-patchlevel to 6.2.0

This won't be fixed for 6.0 and 6.1 since the FAL in these branches has to many conceptional flaws

Actions #8

Updated by Steffen Ritter over 10 years ago

  • Assignee set to Steffen Ritter
Actions #9

Updated by Steffen Ritter over 10 years ago

  • % Done changed from 0 to 100
  • Estimated time set to 0.00 h
  • Complexity set to medium
Actions #10

Updated by Steffen Ritter over 10 years ago

  • Parent task set to #54267
Actions #11

Updated by Steffen Ritter over 10 years ago

  • % Done changed from 100 to 70
Actions #12

Updated by Frans Saris over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 70 to 100
Actions #13

Updated by Steffen Ritter over 10 years ago

  • % Done changed from 100 to 90
Actions #14

Updated by Steffen Ritter over 10 years ago

  • % Done changed from 90 to 100
Actions #15

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF