Feature #5369

URL's - with or without protocol?

Added by Søren Madsen about 10 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2009-11-15
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

This is a general inconsistency issue throughout the backend.

Two examples when adding domain records
The "Domain" must not contain "http://" whereas the "Redirect to" record must have "http://". Leaving it in, or leaving it out in the wrong place, yields an error - and there's no help or label text that explains what I should do.

A third variant of entering URLs, is when creating a Page as an "External" URL. There I get a drop down box, where I select the protocol, but I will more than likely have the URL I wish to use in my clipboard, and I will then paste that complete URL into "URL" - and that will also give me erroneous behavior - most likely because of doubled http://http://mydomain.com

A fourth variant of the inconsistency is when adding a link to text (with RTE). Here the protocol is prewritten for me:

urls-withorwithouthttp.png View (12.9 KB) Søren Madsen, 2009-11-15 09:01

urls-withorwithouthttp2.png View (15.4 KB) Søren Madsen, 2009-11-15 09:01

urls-withorwithouthttp3.png View (14.1 KB) Søren Madsen, 2009-11-15 09:01


Related issues

Related to TYPO3 Core - Feature #71306: Drop "Protocol" field from page type "Link to external URL" Closed 2015-11-04

History

#1 Updated by Søren Madsen about 10 years ago

Deleted unnecessary comment

#2 Updated by Jens Hoffmann almost 7 years ago

  • Target version deleted (TYPO3 4.4)

#3 Updated by Jens Hoffmann about 6 years ago

  • Status changed from New to Accepted
  • Target version set to TYPO3 6.2 LTS

Fine for me.

#4 Updated by Jens Hoffmann about 6 years ago

We decided to drop the Protocol selector, as the "Auto" works fine for all given Protocols.

#5 Updated by Benni Mack about 3 years ago

  • Project changed from v4 Usability Team to TYPO3 Core
  • Category changed from Inconsistency to Backend User Interface

#6 Updated by Riccardo De Contardi over 2 years ago

  • Target version deleted (TYPO3 6.2 LTS)

#7 Updated by Riccardo De Contardi about 2 years ago

In 9.0.0-dev latest master the ""External" URL" pages have lost the protocol field; the remaining observations made here are still valid.

#8 Updated by Benni Mack over 1 year ago

  • Status changed from Accepted to Closed

we're going with "always stick to the protocol". We resolved the External URL dropdown, we also have the protocol as a must-have, and we are going to kick out sys_domain in v10 (which will be the final straw).

Mainly due to consistency in APIs and UX, but also to have full transparency of any new protocols, ports etc.

Also available in: Atom PDF