Bug #53970

getBaseValidatorConjunction is called for simple types

Added by Alexander Stehlik almost 6 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2013-11-26
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I could observe this issue in the TYPO3\CMS\SysNote\Controller\NoteController->listAction:

The $pids argument is of type string. Still getBaseValidatorConjunction() is called which will return nothing because it does a class_exists() check at the beginning.

Since class_exists() seems to be expensive (autoload process is triggered) it could make sense to do a check with TypeHandlingUtility::isSimpleType() before doing the class_exists() check.


Related issues

Related to TYPO3 Core - Bug #53962: Class loader does not cache non existing classes Closed 2013-11-25
Related to TYPO3 Core - Bug #54057: Recursive validation validates too deep New 2013-11-28

History

#1 Updated by Alexander Schnitzler almost 6 years ago

  • Status changed from New to Accepted

We are into the issues of the validation api backport and we are planning to have a codesprint in january to fix these.

#2 Updated by Alexander Opitz about 5 years ago

  • Status changed from Accepted to Needs Feedback

Hi,

was this issue fixed or does it still exists?

#3 Updated by Alexander Stehlik about 5 years ago

The initializeControllerArgumentsBaseValidators() method in the AbstractController class is still calling getBaseValidatorConjunction() which does a class_exists() check at the beginning. The issue is still existing but since #53962 was merged is is not that big of a problem any more I think.

You could still consider adding a check for TypeHandlingUtility::isSimpleType() which might be cheaper than class_exists() but this would need some performance testing.

#4 Updated by Alexander Opitz about 5 years ago

  • Project changed from Extbase MVC Framework to TYPO3 Core
  • Category changed from Extbase: Validation to Extbase
  • Status changed from Needs Feedback to New
  • TYPO3 Version set to 6.2
  • Is Regression set to No

#5 Updated by Mathias Schreiber almost 2 years ago

  • Status changed from New to Closed

Fixed

Also available in: Atom PDF