Project

General

Profile

Actions

Bug #54122

closed

No RTE in IE11

Added by André Spindler about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2013-12-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If You open any record in TCE with enable RTE, the RTE is not loaded.
You get just an textarea field with the compiled HTML code as content.

Might be caused by the new format of the useragent string?

Affected are at least versions 6.1 and 4.5, perhaps also 4.7, 6.0 and 6.2.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #54124: Extend useragent-checks to include IE11Closed2013-12-01

Actions
Actions #1

Updated by André Spindler about 10 years ago

Now verified the affected versions:
4.5.31
4.7.16
6.0.11
6.1.6
6.2.0beta2

Actions #2

Updated by Markus Klein about 10 years ago

  • Status changed from New to Accepted
  • TYPO3 Version changed from 6.1 to 4.5
Actions #3

Updated by Stefan Neufeind about 10 years ago

From reading the source I guess this should work when ClientUtility correctly detects "msie". For general IE11-detection-support see #54124.

Actions #4

Updated by Stefan Neufeind about 10 years ago

Markus confirmed in #54124 that the patch there (IE11-detection) also brings back the RTE in MSIE11. Please give the patch over there a try.

Actions #5

Updated by André Spindler about 10 years ago

Patch in #54124 works for me, too.
RTE is back in 6.1 with IE11.
Also added patch manually to 4.5.31 and it works also there.

Thanks!

Actions #6

Updated by Georg Ringer about 10 years ago

  • Status changed from Accepted to Closed

closed being a duplicate

Actions

Also available in: Atom PDF