Task #54237

Epic #55070: Workpackages

Epic #54260: WP: FAL Missing Issues / Features / API

Story #54266: As an User I want FAL to be performant

filemetadata adds extremely slow MM-relation to fe_groups

Added by Stefan Froemken over 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-12-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
easy
Sprint Focus:

Description

Hello Core-Team,

if filemetadate-extension is installed it adds an extremely slow MM-Relation to file_mata_data-table.
Please install this extension and try to open an fe_group record in BE listmodule. As more file-meta_data exists as slower the records will open. In our case we have 54.000 filemetadata records, and for each record it executes 54.000 queries to retrieve the title of sys_file. We have to wait nearly 5 minuten to edit an fe_group record. And please have a look into sys_file_fegroups_mm. It's EMPTY! So why search for things which aren't there?

Stefan


Related issues

Related to TYPO3 Core - Feature #52719: Advanced metadata for FileClosed2013-10-12

Actions
Is duplicate of TYPO3 Core - Task #54236: sys_file_metadata uses mm for fe_group fieldClosedSteffen Ritter2013-12-06

Actions
#1

Updated by Steffen Ritter over 7 years ago

  • Status changed from New to Accepted
  • Assignee set to Steffen Ritter
  • Priority changed from Should have to Must have
#2

Updated by Steffen Ritter over 7 years ago

  • Parent task set to #54266
#3

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25987

#4

Updated by Steffen Ritter over 7 years ago

  • Status changed from Under Review to Resolved
#5

Updated by Steffen Ritter over 7 years ago

  • % Done changed from 0 to 90
#6

Updated by Steffen Ritter about 7 years ago

  • % Done changed from 90 to 100
#7

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF