Story #54567

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Epic #55656: Optimize overall Extbase performance

Extbase: overall performance of backend modules

Added by Felix Oertel almost 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extbase
Target version:
Start date:
2013-12-22
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Sprint Focus:

Description

The performance of backendmodules seems to be very bad. We have to analyze that and look, how to improve.

This is just an umbrella issue, if you want to discuss specific issues, please open sub-issues. thanks.

dbLayout.jpg View (42.2 KB) Michiel Roos, 2013-12-22 21:51


Subtasks

Task #54571: Extbase: Avoid TS parsing in BE if not necessaryClosedFelix Oertel

Task #55653: belog: cache the beusers usernameClosed

History

#1 Updated by Felix Oertel almost 6 years ago

I looked through the issue tracker of both extbase and cms core and did not find any unresolved tickets for this topic. if you know of some, please relate ...

#2 Updated by Michiel Roos almost 6 years ago

Please find attached a screenshot of a diff between two profiling runs of a 6.2 installations.

One (run2) has the sys_note extension loaded and the other has not.

You see a 300% increase in number of function calls. Also a 500% increase in load time.

I'll try do dig some more.

#3 Updated by Felix Oertel almost 6 years ago

Hey Michiel,

thanks for sharing. Would you mind, opening a sub-issue for that?

regards, foertel

#4 Updated by Michiel Roos almost 6 years ago

Hi Felix. A sub issue? This is one issue. The problem is indeed the TypoScript parsing. The total callgraph looks horrible. There is a lot of TYPO3\CMS\Core\TypoScript\Parser\TypoScriptParser::parseSub@n going on. All is initiated by TYPO3\CMS\Core\TypoScript\TemplateService::generateConfig. I don't see anything like this for frontend pages with extbase extensions. I don't understand why the normal and fast runthroughTemplates is not enough to get the TS.

#5 Updated by Felix Oertel almost 6 years ago

Yeah, it's not, that I don't believe you, that there is a problem. :) It's just, that there are more probems like that and I wanted to have this as kind of an umbrella issue. The TS parsing is over in #54571.

#6 Updated by Marc Bastian Heinrichs over 5 years ago

  • Parent task set to #55656

#7 Updated by Ernesto Baschny over 5 years ago

  • Project changed from Extbase MVC Framework to TYPO3 Core
  • Category deleted (Extbase: Core)

#8 Updated by Ernesto Baschny over 5 years ago

  • Tracker changed from Bug to Story
  • Subject changed from overall performance of backend modules to Extbase: overall performance of backend modules
  • Category set to Extbase
  • TYPO3 Version set to 6.2

#9 Updated by Felix Oertel over 5 years ago

  • Status changed from Accepted to Closed

Also available in: Atom PDF