Epic #55656

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Optimize overall Extbase performance

Added by Marc Bastian Heinrichs almost 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-06-08
Due date:
2014-07-09
% Done:

100%

Estimated time:
(Total: 24.00 h)
Sprint Focus:

Description

Umbrella Task


Subtasks

Task #55654: Extbase: Optimize ClassInfoFactory with the ClassInfoCacheClosedMarc Bastian Heinrichs2014-02-04

Actions
Story #55168: Optimize Extbase generic persistenceClosedFelix Oertel2013-11-112014-07-09

Actions
Task #55167: Extbase: avoid parseQuery() / buildQuery() to be called multiple timesClosedFelix Oertel2014-03-202014-03-20

Actions
Task #55661: Add functional tests for extbase persistenceClosedFelix Oertel2014-03-202014-03-20

Actions
Task #57173: Use of cf_extbase_typo3dbbackend_queries results in fatalClosedXavier Perseguers2014-03-22

Actions
Task #57130: Extbase Queries with NULL comparison don't work anymoreClosed2014-03-21

Actions
Task #57104: Regression: Query building fails for LazyObjectStorageClosed2014-03-20

Actions
Task #57263: Typo3DbQueryParser does not handle LowerCaseInterface correctlyClosedFelix Oertel2014-03-25

Actions
Task #57338: Make Typo3DbQueryParser SingletonClosed2014-03-26

Actions
Task #55169: Extbase: fetch child objects in one queryRejectedFelix Oertel2014-07-22

Actions
Feature #60460: Refactor lazyLoading handling in extbaseClosedFelix Oertel2014-07-22

Actions
Task #53514: Extbase: DataMapper causes redundant queriesClosedNico de Haen2013-11-11

Actions
Task #55360: Extbase: use preparedStatement in generic persistenceClosedFelix Oertel2014-03-19

Actions
Task #57067: Follow-Up re-use preparedStatement objectRejectedFelix Oertel2014-03-19

Actions
Task #57254: Fix usage of own prepared statement object in $query->statementClosed2014-03-24

Actions
Task #56979: Add setting for DataMapper to enable preparedStatementsClosed2014-03-17

Actions
Task #59917: User Repositories in internal persistence logicRejectedFelix Oertel2014-06-272014-07-09

Actions
Story #54567: Extbase: overall performance of backend modulesClosedFelix Oertel2013-12-22

Actions
Task #54571: Extbase: Avoid TS parsing in BE if not necessaryClosedFelix Oertel2013-12-22

Actions
Task #55653: belog: cache the beusers usernameClosed2014-02-04

Actions
Feature #48960: Extbase: Backport lazy dependency injectionRejectedMarc Bastian Heinrichs2013-06-08

Actions
Story #55079: review Extbase caching for frontend and backendClosed2014-01-02

Actions
Task #55044: Make Extbase use cache group "pages"ClosedBenni Mack2014-01-16

Actions
Task #54701: Cache global TypoScript template in backendClosedFelix Oertel2014-01-02

Actions
Task #57594: Optimize ReflectionService Cache handlingClosedMarc Bastian Heinrichs2017-05-31

Actions
Feature #81389: Injected ReflectionService without call to initialize/shutdownClosed2017-05-31

Actions
Task #54605: Inject annotations should not be used by core (~5% performance)ClosedMarc Bastian Heinrichs2013-12-26

Actions
#1

Updated by Ingo Schmitt almost 7 years ago

  • Parent task set to #55065
#2

Updated by Felix Kopp almost 6 years ago

  • Status changed from New to Accepted

can this epic be closed?

#3

Updated by Riccardo De Contardi about 5 years ago

I don't know... I see that there are still open issues, but:

- Task #55169 has a patch (http://review.typo3.org/32286) abandoned since june (same patch as Feature #60460 and Task #59917)
- Feature #48960 has a patch (https://review.typo3.org/27001) abandoned since january
- Task #54701 has a patch (https://review.typo3.org/26876) abandoned since august 2014

- Task #56979 is still open
- Task #57594 is still open
- Task #54813 is still open

#4

Updated by Mathias Schreiber about 5 years ago

  • Target version deleted (6.2.0)
#5

Updated by Benni Mack about 3 years ago

  • Status changed from Accepted to Closed

Also available in: Atom PDF