Bug #55847

Bug #55830: Cleanup mess with treeView implementations

Remove empty classes implementing AbstractTreeView

Added by Tymoteusz Motylewski almost 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Code Cleanup
Target version:
-
Start date:
2014-02-10
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

There are 3 empty classes:
Rtehtmlarea\ImageFolderTree
rteFolderTree from class.browse_links_php
rtePageTree from class.browse_links_php

We should remove them as the tree implementation is already too complex see http://forge.typo3.org/issues/55830

Associated revisions

Revision be558f4f (diff)
Added by Tymoteusz Motylewski almost 6 years ago

[!!!][TASK] Remove empty classes implementing AbstractTreeView

The tree class hierachie contains 3 empty classes, removed
by the patch:

  • \TYPO3\CMS\Rtehtmlarea\ImageFolderTree
  • rteFolderTree extends localPageTree in class.browse_links.php
  • rtePageTree extends localFoltderTree in class.browse_links.php

Resolves: #55847
Related: #55830
Releases: 6.2
Change-Id: I5d0d92a484c37b6c2812f3350ab3f4dd3dfd15c8
Reviewed-on: https://review.typo3.org/27527
Tested-by: Tymoteusz Motylewski
Reviewed-by: Tymoteusz Motylewski
Reviewed-by: Frans Saris
Tested-by: Frans Saris
Reviewed-by: Markus Klein
Tested-by: Markus Klein

History

#1 Updated by Markus Klein almost 6 years ago

Basically I for cleaning this area massively, but since we never declared which class is part of the official API we might break non-core code by removing them.

I kindly ask the Core Team members to judge on this.

#2 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27527

#3 Updated by Tymoteusz Motylewski almost 6 years ago

this should not be a breaking change, as I've added old classes to classAliasMap

#4 Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27527

#5 Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27527

#6 Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27527

#7 Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27527

#8 Updated by Gerrit Code Review almost 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27527

#9 Updated by Gerrit Code Review almost 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27527

#10 Updated by Tymoteusz Motylewski almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Ernesto Baschny almost 6 years ago

  • Parent task set to #55830

#12 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF