Bug #55830

Cleanup mess with treeView implementations

Added by Tymoteusz Motylewski almost 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Code Cleanup
Target version:
Start date:
2014-02-10
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently we have ~17 classes inheriting from Backend\Tree\View\AbstractTreeView class
(not counting legacy classes from before namespace change).
We have several classes with the same names (from different namespaces) like:
Backend\Tree\View\PageTreeView
Backend\View\PageTreeView
or

Impexp\LocalPageTree
localPageTree from class.browse_links_php
localPageTree from db_new_php
localPageTree from move_el_php

It might be ok to have the same names across namespaces, but if it's combined with other issues, it makes really hard to understand this area of the core.

There are also 3 empty classes:
Rtehtmlarea\ImageFolderTree
rteFolderTree from class.browse_links_php
rtePageTree from class.browse_links_php

See attached diagrams of classes. One is with legacy classes, second one is without.

Because of this mess behaviour and look of trees differs in different parts of the backend (Link wizard, RTE link wizard, folder selector, file selector, image selector, RTE image selector,....).
It's also really hard to reuse it in own extension (which base class to inherit?).

implementationsOfAbstractTreeView2.png View (79 KB) Tymoteusz Motylewski, 2014-02-10 10:59

implementationsOfAbstractTreeViewWithLegacyClasses.png View (104 KB) Tymoteusz Motylewski, 2014-02-10 10:59

implementationsOfAbstractTreeView.png View (41 KB) Tymoteusz Motylewski, 2014-02-25 16:50

implementationsOfAbstractTreeView.txt View (2.01 KB) Tymoteusz Motylewski, 2015-07-09 15:39


Subtasks

Bug #55847: Remove empty classes implementing AbstractTreeViewClosedTymoteusz Motylewski

Bug #55876: Rename classes with the same nameClosed


Related issues

Related to TYPO3 Core - Task #64516: Move non-namespaced class into correct places Closed 2015-01-26

Associated revisions

Revision be558f4f (diff)
Added by Tymoteusz Motylewski almost 6 years ago

[!!!][TASK] Remove empty classes implementing AbstractTreeView

The tree class hierachie contains 3 empty classes, removed
by the patch:

  • \TYPO3\CMS\Rtehtmlarea\ImageFolderTree
  • rteFolderTree extends localPageTree in class.browse_links.php
  • rtePageTree extends localFoltderTree in class.browse_links.php

Resolves: #55847
Related: #55830
Releases: 6.2
Change-Id: I5d0d92a484c37b6c2812f3350ab3f4dd3dfd15c8
Reviewed-on: https://review.typo3.org/27527
Tested-by: Tymoteusz Motylewski
Reviewed-by: Tymoteusz Motylewski
Reviewed-by: Frans Saris
Tested-by: Frans Saris
Reviewed-by: Markus Klein
Tested-by: Markus Klein

History

#2 Updated by Felix Kopp almost 6 years ago

Great!!!!!

(Have been working with the trees due to the treelevel sprite icons)

#3 Updated by Felix Kopp almost 6 years ago

There are further trees hidden in TemplateService / DocumentTemplate for TypoScript, PageTS and more.

#4 Updated by Tymoteusz Motylewski almost 6 years ago

Uploaded new class diagram after #55847 and #55876 were merged.

#5 Updated by Anja Leichsenring almost 5 years ago

  • Sprint Focus set to On Location Sprint

#6 Updated by Benni Mack almost 5 years ago

  • Status changed from New to Resolved
  • Target version set to 7.1 (Cleanup)

done now.

#7 Updated by Tymoteusz Motylewski over 4 years ago

Uploading source code for diagrams. It was generated with tool called "plantuml"
http://plantuml.sourceforge.net/classes.html

#8 Updated by Anja Leichsenring almost 4 years ago

  • Sprint Focus deleted (On Location Sprint)

#9 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF