Bug #56303

Button-Labels are hidden in Workspace-Dialog-Box

Added by Thomas Sperling almost 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2014-02-26
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

If you are in the Workspace-preview and you want to remove or publish the draft you get a dialog-box, which has no text on its buttons.

In the markup the text is present, but the styling is broken, so you cant see the labels.
All stylings and script are loaded correctly.

I use TYPO3 6.2 beta5

workspace.png View (2.9 KB) Thomas Sperling, 2014-02-26 10:28

56303.diff View (601 Bytes) Hercules Karvasonis, 2014-09-04 16:30

45.png View (8.97 KB) nemo m, 2015-02-03 16:09


Related issues

Related to TYPO3 Core - Bug #58441: Displaced button in workspace preview toolbar Closed 2014-05-03
Duplicates TYPO3 Core - Bug #65102: Styling of "Ready-to-publish" JS-window Closed 2015-02-16

History

#1 Updated by Markus Klein almost 6 years ago

@Felix: Without testing this, it looks like ExtJS styling again broken here. Can you take a look please?

#2 Updated by Oliver Hader almost 6 years ago

  • Status changed from New to Needs Feedback

Works with current master (TYPO3 6.2.0 RC1).
Can you please clear the caches and re-check on your system?

#3 Updated by Thomas Sperling almost 6 years ago

I have now TYPO3 6.2 final and the Button lanles are still missing. I cleared the cache and everything else a lot.

#4 Updated by Oliver Hader over 5 years ago

  • Status changed from Needs Feedback to Accepted
  • Assignee set to Oliver Hader
  • Target version set to next-patchlevel
  • PHP Version set to 5.3
  • Complexity set to medium

Sorry, it's in the frontend preview not in the backend workspace module view. I could reproduce the bug...

#5 Updated by Hercules Karvasonis over 5 years ago

That's a CSS issue.
I attached a diff file that is fixing this issue.

Thanks,
Hercules.

#6 Updated by Mathias Schreiber almost 5 years ago

  • Target version changed from next-patchlevel to 7.5

#7 Updated by nemo m almost 5 years ago

This bug seems to be introduced in 0d0beaf3959ef4c915e7b4db32a64c4a6a93b022 of #52497 since it modifies typo3/sysext/t3skin/Resources/Public/Css/visual/main_form.css and removes the necessary font-height attribute for buttons.

Also noteworthy is the height difference in the workspace preview toolbar which is introduced by the font-size changes in sysext/workspaces/Resources/Public/StyleSheet/preview.css. I attached an image.

This error seems to occur in the first place because instead of the t3skin ExtJS theme, sysext/workspaces/Resources/Public/StyleSheet/preview.css is used as ExtJS theme.

A temporary workaround is to revert the two CSS files to their previous state:

git checkout 0d0beaf3959ef4c915e7b4db32a64c4a6a93b022~1 -- \
sysext/t3skin/Resources/Public/Css/visual/main_form.css \
sysext/workspaces/Resources/Public/StyleSheet/preview.css

#8 Updated by Oliver Hader over 4 years ago

  • Status changed from Accepted to Closed

The button thingy has been fixed with #65102. The preview header issue in the frontend is a duplicate of #58441

Also available in: Atom PDF