Bug #56322

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Bug #52949: Speed decrease since 4.5

Bug #56307: Findings from Bootstrap/PackageManager/ClassLoader analyses

GetAliasesForClass not used

Added by Steffen Ritter over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-02-26
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Check what this could be helpful for and remove that methods as well as the in memory map for that.

History

#1 Updated by Thomas Maroschik over 5 years ago

getAliasForClassName is wrong, because there can be multiple aliases for a single class. getAliasesForClassName has been introduced to tackle this and getAliasForClassName is deprecated.

#2 Updated by Benni Mack almost 5 years ago

  • Status changed from New to Closed

this is tackled. getAliasForClass is removed with CMS7.

Also available in: Atom PDF